stylo: Setting system font to CanvasRenderingContext2D and getting back works correctly in stylo but not gecko

RESOLVED WONTFIX

Status

()

P5
normal
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: xidorn, Unassigned)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

Trunk
dev-doc-complete
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox59 ?)

Details

(Reporter)

Description

2 years ago
The following code:
<canvas></canvas>
<script>
let canvas = document.querySelector('canvas');
let ctx = canvas.getContext('2d');
ctx.font = 'menu';
alert(ctx.font);
</script>

works as expected (shows 'menu') in Stylo, but fails (shows nothing) in Gecko.
(Reporter)

Comment 1

2 years ago
dom/canvas/test/test_canvas_font_setter.html has a todo_is for this, which is unexpected pass on Stylo.
(Reporter)

Updated

2 years ago
Priority: -- → P5
Marking as part of documentation plan for intentional stylo differences, in case this is fixed before the stylo switchover gets into release. But not worth mentioning in the docs otherwise.
Keywords: dev-doc-needed
(Reporter)

Comment 4

2 years ago
I think the document is opposite on this as well. It is another bug that exists in Gecko fixed by Stylo.
Flags: needinfo?(cmills)
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #4)
> I think the document is opposite on this as well. It is another bug that
> exists in Gecko fixed by Stylo.

Oops. I've fixed this now. Thanks for spotting it!
Flags: needinfo?(cmills)
status-firefox57: --- → wontfix
status-firefox58: --- → fix-optional

Comment 7

a year ago
(In reply to Firefox Product Integrity Bug Husbandry Bot (contact :emceeaich) from comment #6)
> status-firefox58: fix-optional → wontfix
> status-firefox59: --- → ?

No work in 59.0.1
http://file-store.rosalinux.ru/api/v1/file_stores/cfc9e8c9d2f43cd4a05f98934be034cf58e83568.log?show=true
(Reporter)

Comment 8

a year ago
Closing bugs existing only in the old style system.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

a year ago
(In reply to ch6ru from comment #7)
> (In reply to Firefox Product Integrity Bug Husbandry Bot (contact
> :emceeaich) from comment #6)
> > status-firefox58: fix-optional → wontfix
> > status-firefox59: --- → ?
> 
> No work in 59.0.1
> http://file-store.rosalinux.ru/api/v1/file_stores/
> cfc9e8c9d2f43cd4a05f98934be034cf58e83568.log?show=true

What is not working? The file seems to be a log and I don't know what to see from it.
Flags: needinfo?(alzim)

Comment 10

a year ago
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #9)

> What is not working? The file seems to be a log and I don't know what to see
> from it.

20:34.58 error: failed to run custom build command for `style v0.0.1 (file:///builddir/build/BUILD/firefox-59.0.1/servo/components/style)`
20:34.58 process didn't exit successfully: `/builddir/build/BUILD/obj/toolkit/library/release/build/style-5fbf2b408c8a8b6a/build-script-build` (exit code: 101)
Flags: needinfo?(alzim)
(Reporter)

Comment 11

a year ago
(In reply to ch6ru from comment #10)
> 20:34.58 error: failed to run custom build command for `style v0.0.1
> (file:///builddir/build/BUILD/firefox-59.0.1/servo/components/style)`
> 20:34.58 process didn't exit successfully:
> `/builddir/build/BUILD/obj/toolkit/library/release/build/style-
> 5fbf2b408c8a8b6a/build-script-build` (exit code: 101)

This seems to be a build issue unrelated to this bug. Please file a new bug for this.

It seems the issue is
> 20:34.74 /builddir/build/BUILD/obj/dist/include/mozilla/Compiler.h:49:12: fatal error: 'cstddef' file not found
I'm not sure what could lead to that, probably some configuration with clang has some problem.
You need to log in before you can comment on or make changes to this bug.