Status

()

enhancement
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: emk, Assigned: emk)

Tracking

(Blocks 1 bug)

unspecified
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(3 attachments)

It is merged into nsIFile and is left only for compatibility.
Depends on: 1387017
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6b0c63a3e42623ed38f87bba156db0e19f31b6ef
Windows buildbot builds and jetpack-package-clipboard are known permafail.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Comment on attachment 8894042 [details]
Bug 1375125 - Stop using nsILocalFile in the tree.

https://reviewboard.mozilla.org/r/165140/#review170546

r=me assuming this was done by something like `perl -p -i -e 's/nsILocalFile/nsIFile/' ...`
Attachment #8894042 - Flags: review?(nfroyd) → review+
Comment on attachment 8894043 [details]
Bug 1375125 - Fix errors caused by mechanical replacement.

https://reviewboard.mozilla.org/r/165142/#review170548

::: addon-sdk/source/lib/sdk/io/fs.js:21
(Diff revision 1)
>  
>  const { ns } = require("../core/namespace");
>  const { Class } = require("../core/heritage");
>  
>  
> -const nsIFile = CC("@mozilla.org/file/local;1", "nsIFile",
> +const LocalFile = CC("@mozilla.org/file/local;1", "nsIFile",

This change isn't strictly necessary, is it?  It's just making things more consistent?
Attachment #8894043 - Flags: review?(nfroyd) → review+
Comment on attachment 8894043 [details]
Bug 1375125 - Fix errors caused by mechanical replacement.

https://reviewboard.mozilla.org/r/165142/#review170548

> This change isn't strictly necessary, is it?  It's just making things more consistent?

This file has
> var nsIFile = accessor();

later, so it fails with redeclaration of const without this change.
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 1ac5df95d749 -d d9bef5f3594d: rebasing 411788:1ac5df95d749 "Bug 1375125 - Stop using nsILocalFile in the tree. r=froydnj"
other [source] changed security/manager/tools/makeCNNICHashes.js which local [dest] deleted
use (c)hanged version, leave (d)eleted, or leave (u)nresolved? u
merging browser/base/content/browser.js
merging browser/components/places/content/places.js
merging toolkit/content/widgets/preferences.xml
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/f904bc721e7d
Stop using nsILocalFile in the tree. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/56b1b043078b
Fix errors caused by mechanical replacement. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/b34cf908546b
Remove nsILocalFile. r=froydnj
Depends on: 1389449
You need to log in before you can comment on or make changes to this bug.