Closed Bug 1375783 Opened 5 years ago Closed 5 years ago

Make tour notification responsive (so the close button is visible even on a smaller window size)

Categories

(Firefox :: General, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- verified
firefox58 --- verified

People

(Reporter: timdream, Assigned: timdream)

References

Details

(Whiteboard: [photon-onboarding])

Attachments

(1 file, 1 obsolete file)

I am seeing complain on Slack that it's not obvious how to dismiss the tour notification, and get to the about:home launchers. It turned out the current design sets the minimum width to 1060px (!) and the close button is simply cut off on a small screen.

I have a band-aid patch (not part of the spec) to at least make sure the close button is visible.
Attached image Screen Shot 2017-06-23 at 3.11.44 PM.png (obsolete) —
The added style makes the body text narrower on the smaller window, and hides the left-most "New to Nightly?" button to make way for other things. The body text is scrollable on the y-axis when the text overflows. The layout remains unchanged on non-narrow windows.

Narrow = width smaller or equal to 960px (totally a made up number).
Attachment #8880723 - Flags: ui-review?(mverdi)
Comment on attachment 8880722 [details]
Bug 1375783 - Make onboarding tour notification responsive,

https://reviewboard.mozilla.org/r/152084/#review157046

Thanks for this. This looks good to me. Just thah, this is going to be differrent from the current UI requirements so let's see verdi's thought.
Attachment #8880722 - Flags: review?(fliu) → review+
Comment on attachment 8880722 [details]
Bug 1375783 - Make onboarding tour notification responsive,

https://reviewboard.mozilla.org/r/152084/#review157270
Attachment #8880722 - Flags: review?(dtownsend) → review+
Comment on attachment 8880723 [details]
Screen Shot 2017-06-23 at 3.11.44 PM.png

Talked to verdi in person and we tweaked the dimensions a little bit, to a place we are happy with. I am going to push the patch to mozreview and land this.
Attachment #8880723 - Attachment is obsolete: true
Attachment #8880723 - Flags: ui-review?(mverdi)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e1284ab0a1a9
Make onboarding tour notification responsive, r=Fischer,mossop
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e1284ab0a1a9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify+
QA Contact: jwilliams
This issue has been verified on Win 10 x64.
Status: RESOLVED → VERIFIED
Priority: P3 → P1
Whiteboard: [photon-onboarding] → [reserve-photon-onboarding]
Priority: P1 → P3
Whiteboard: [reserve-photon-onboarding] → [photon-onboarding]
Duplicate of this bug: 1377323
Note that the tour itself is not responsive. At 150% zoom level I can't see the select button at the end to dismiss the tour indefinitely.

I filed bug 1379026 about this.
Note that with bug 1358970 the notification will simply be hidden with smaller window size.
I have verified that the close button is visible on smaller screen sizes on Win 10 x64, Win 7 x32, Ubuntu 16.04 x32, and Mac 10.12 with Firefox 58.
You need to log in before you can comment on or make changes to this bug.