Tearing off tabs causes a reload of the page

RESOLVED DUPLICATE of bug 1374025

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1374025
6 months ago
6 months ago

People

(Reporter: whimboo, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0 ID:20170621030208 CSet: e1e4a481b7e88dce163b9cccc2fb72032023befa

Whenever I tear off a tab its content get reloaded. I noticed that when working with one-click loaners via Treeherder.

Steps:

1. Open https://tools.taskcluster.net/one-click-loaner/#Tcn9ZzzhSoS4WSmOh7oZ4g
2. Login and create a one click loaner
3. Wait until the loaner has been created
4. Open a root shell or a VNC screen
5. Tear off the tab

With step 5 I only see a white page with nothing loaded. Any running shell or VNC connection is lost.

Comment 1

6 months ago
Feels like a dupe of bug 1374025.
See Also: → bug 1374025
(Reporter)

Comment 2

6 months ago
By doing the above steps the following error is visible in the browser console:

> 14:10:20.042 TypeError: aRequestOrigin is null[Learn More]  policy.js:94:5
(Reporter)

Comment 3

6 months ago
(In reply to :Gijs from comment #1)
> Feels like a dupe of bug 1374025.

It's the same behavior for those pages, indeed.
I'm a little confused why I was copied here -- I don't know what it means to "tear off a tab", but I don't think it has to do with Taskcluster... anyway, seems there is agreement it's a dupe..
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374025
You need to log in before you can comment on or make changes to this bug.