"Touch-enabled" display density (AKA display mode) is not available in Gmail

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
a year ago
2 months ago

People

(Reporter: billdillensrevenge, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Google][platform-rel-Gmail])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8880785 [details]
ffctedm.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170608105825

Steps to reproduce:

using a Windows device that has a touchscreen, when in Gmail in Chrome and Edge, there is a "Touch-enabled" option, but when I sign into Gmail in Firefox, the option is not there. see attached screenshot
Component: Untriaged → DOM: Events
Product: Firefox → Core
See relative comment https://bugzilla.mozilla.org/show_bug.cgi?id=906034#c2 I wonder if there's anything we could do on our side, we probably should reach to google to see how we could get this feature on on firefox.

Flagging on :dees to put this on our PM's radar.
Flags: needinfo?(dchinniah)
platform-rel: --- → ?
Flags: needinfo?(dchinniah)
Whiteboard: [platform-rel-Google][platform-rel-Gmail]
(In reply to Hsin-Yi Tsai (55 Regression Engineering support) [:hsinyi] from comment #1)
> See relative comment https://bugzilla.mozilla.org/show_bug.cgi?id=906034#c2
> I wonder if there's anything we could do on our side, we probably should
> reach to google to see how we could get this feature on on firefox.
> 
> Flagging on :dees to put this on our PM's radar.

Likely one for Webcompat...
Flags: needinfo?(miket)
Flags: needinfo?(astevenson)
Thanks -- usually Karl would reach out but he's on PTO for 2 weeks. Adam can you get in touch via our ML?
Flags: needinfo?(miket)
Sure. Email sent via the partner mailing list.
Flags: needinfo?(astevenson)
Thanks Adam -- looks like we need Bug 1035774 implemented before this feature will work.
Depends on: 1035774
Also, a Gmail engineer said:

> [W]e're restricting by user-agent as well. We can look into whitelisting Firefox for touch after support for any-pointer is added.
P3 but nothing to really do in this bug.
Priority: -- → P3
platform-rel: ? → +
(Reporter)

Comment 8

7 months ago
Kinda some good news about this bug: it seems as of the new Gmail design, the "Touch-enabled" option no longer exists. Maybe someone should double check with Google and if it indeed no longer exists, this bug can be closed
Closing as per comment 8.
Even if there is still the option, it should just work since bug 1035774 landed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.