Nightly 2017-06-23 broken for Persian language

RESOLVED DUPLICATE of bug 1376000

Status

()

RESOLVED DUPLICATE of bug 1376000
a year ago
a year ago

People

(Reporter: Arash-M, Unassigned)

Tracking

56 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
What happened

Nightly had an update, after pressing the button for restarting Nightly, Nightly got open all tabs had no title and it was showing an error on page "Oops! this tab seems broken". Restarted the browser again, all tabs were gone. Trying to open a new tab shows the same "Oops" error page.

What I did

- Tried to test with a new Firefox profile, it didn't work.
- Downloaded today's nightly from Mozilla website[1], it has the same problem

System Information

OS: Arch Linux x86_64
Kernel: 4.11.6-1-ARCH
Shell: /usr/bin/fish
Window Manager: GNOME
RAM: 4314M / 15869M (27%)
CPU: Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz

[1] https://download.mozilla.org/?product=firefox-nightly-latest-l10n-ssl&os=linux64&lang=fa
(Reporter)

Comment 1

a year ago
Errors I get when opening using `firefox-nightly --safe-mode` in command line:

```
thread '<unnamed>' panicked at 'SinkInfo contains invalid flags', /checkout/src/libcore/option.rs:794
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Redirecting call to abort() to mozalloc_abort

thread '<unnamed>' panicked at 'SinkInfo contains invalid flags', /checkout/src/libcore/option.rs:794
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Redirecting call to abort() to mozalloc_abort

[Parent 29949] WARNING: pipe error (58): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (63): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (61): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error: Broken pipe: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 709
[Parent 29949] WARNING: pipe error (84): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (89): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (87): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error: Broken pipe: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 709
thread '<unnamed>' panicked at 'SinkInfo contains invalid flags', /checkout/src/libcore/option.rs:794
note: Run with `RUST_BACKTRACE=1` for a backtrace.
Redirecting call to abort() to mozalloc_abort

[Parent 29949] WARNING: pipe error (75): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (123): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[Parent 29949] WARNING: pipe error (119): Connection reset by peer: file /home/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353

###!!! [Parent][MessageChannel] Error: (msgtype=0x280080,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
```
I downloaded the build in [1] and it works fine for me (on en-US Ubuntu x86-64), fwiw.
Long shot: does including Stylo in the build have new requirements on the runtime environment?
Flags: needinfo?(gps)
(Reporter)

Comment 4

a year ago
Created attachment 8880837 [details]
Screencast 2017-06-23 19:36:07.mp4

Not sure if it helps, but here is a small screencast of what happens. It still occurs with Firefox en_US. So it shouldn't be a problem with locale really.
(In reply to Mats Palmgren (:mats) from comment #3)
> Long shot: does including Stylo in the build have new requirements on the
> runtime environment?

Uh, I don't think so. But this is outside my area of expertise.

Can you try running a build from earlier in the week? How about https://queue.taskcluster.net/v1/task/TOCNyWGQQretFMD7G5RC8g/runs/0/artifacts/public/build/target.tar.bz2 . This is a build with Stylo enabled. So if it works, it probably isn't enabling Stylo that caused problems. If it doesn't work, then, yeah, we should go looking for new dependencies introduced by building Stylo.
Flags: needinfo?(gps)
Bug 1376000 is about a recent crash with "SinkInfo.flags", so I'm assuming
it's fixing this bug.

Arash, please confirm it works for you in a few days after those changes
makes it into a Nightly.  Thanks for your report!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1376000
Arash, there is also a temporary workaround mentioned in Bug 1376000 Comment 1.
(Reporter)

Comment 8

a year ago
It seems to be fixed now. Thank you.
You need to log in before you can comment on or make changes to this bug.