Closed Bug 137600 Opened 18 years ago Closed 13 years ago

.netscape-s left in converted profile

Categories

(Core Graveyard :: Profile: Migration, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla, Assigned: sspitzer)

Details

When creating a new profile by conversion of the Netscape 4.7x profile, Mozilla
left lots of .netscape stuff in the new profile, among them the ones below, but
several more, which I deleted from the created file (even for the bookmarks). I
have tried it with Mozilla-0.9.9+ (20020415).

user_pref("browser.history_file", "/home/leo/weilbach/.netscape/history.db");
user_pref("browser.sarcache.directory", "/home/leo/weilbach/.netscape/archive/");
user_pref("browser.user_history_file", "/home/leo/weilbach/.netscape/history.list");
user_pref("mail.root.none", "/home/leo/weilbach/.netscape/Mail");
what's the status of this? problem still there? or it this a feature or what?
I just tried again with Mozilla 1.1b, and I still see the same:

~ > mv .mozilla mozilla-profile
~ > mozilla
             --> choose "Convert profile"
~ > cd .mozilla/`whoami`/*.slt
~/.mozilla/weilbach/0q86xk19.slt > grep -i netsc prefs*
prefs.bak:// Netscape User Preferences
prefs.bak:user_pref("browser.bookmark_file",
"/home/leo/weilbach/.netscape/bookmarks.html");
prefs.bak:user_pref("browser.cache.directory",
"/home/leo/weilbach/.netscape/cache");
prefs.bak:user_pref("browser.history_file",
"/home/leo/weilbach/.netscape/history.db");
prefs.bak:user_pref("browser.sarcache.directory",
"/home/leo/weilbach/.netscape/archive/");
prefs.bak:user_pref("browser.user_history_file",
"/home/leo/weilbach/.netscape/history.list");
prefs.bak:user_pref("mail.directory", "/home/leo/weilbach/.netscape/Mail");
prefs.bak:user_pref("news.directory", "/home/leo/weilbach/.netscape/News");
prefs.js:user_pref("browser.bookmark_file",
"/home/leo/weilbach/.netscape/bookmarks.html");
prefs.js:user_pref("browser.cache.directory", "/home/leo/weilbach/.netscape/cache");
prefs.js:user_pref("browser.history_file",
"/home/leo/weilbach/.netscape/history.db");
prefs.js:user_pref("browser.sarcache.directory",
"/home/leo/weilbach/.netscape/archive/");
prefs.js:user_pref("browser.user_history_file",
"/home/leo/weilbach/.netscape/history.list");
prefs.js:user_pref("mail.directory", "/home/leo/weilbach/.netscape/Mail");
prefs.js:user_pref("news.directory", "/home/leo/weilbach/.netscape/News");
this sounds like commercial version of bug 15424 which was fixed for mozilla only
confirming, adding to cc list
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is not the same as bug 15424 which is about some unused files left after
the migration. This bug is related to some entries in the profile are left after
the migration.
mass re-assign.
Assignee: racham → sspitzer
I tried again with the 1.7 release (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7) Gecko/20040624) and the problem is still there. prefs.js contains the
following lines with netscape:

user_pref("browser.bookmark_file", "/home/pweilba/.netscape/bookmarks.html");
user_pref("browser.cache.directory", "/home/pweilba/.netscape/cache");
user_pref("browser.history_file", "/home/pweilba/.netscape/history.db");
user_pref("browser.sarcache.directory", "/home/pweilba/.netscape/archive/");
user_pref("browser.user_history_file", "/home/pweilba/.netscape/history.list");
user_pref("mail.default_drafts", "mailbox:/home/pweilba/.netscape/Mail/Drafts");
user_pref("mail.default_fcc", "/home/pweilba/.netscape/Mail/Sent");
user_pref("mail.default_templates",
"mailbox:/home/pweilba/.netscape/Mail/Templates");
user_pref("mail.directory", "/home/pweilba/.netscape/Mail/");
user_pref("news.default_fcc", "/home/pweilba/.netscape/Mail/Sent");
user_pref("news.directory", "/home/pweilba/.netscape/News/");
Nobody cares about migrating from NS4 any more and I haven't done that myself in some years, so resolving as WFM.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.