Closed Bug 1376174 Opened 2 years ago Closed 2 years ago

4.56% tp5n main_startup_fileio (windows7-32) regression on push 744f286690d7931afcde3eec90490fe4e6279885 (Fri Jun 23 2017)

Categories

(Core :: Audio/Video: Playback, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jmaher, Assigned: rillian)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=744f286690d7931afcde3eec90490fe4e6279885

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  5%  tp5n main_startup_fileio windows7-32 opt e10s     58,798,567.29 -> 61,479,761.08


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7528

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
:rillian as the patch author of bug 1369932, can you look at this bug and determine why we would be doing 2.5MB of extra fileIO on startup in the main thread?  If this is expected, please document it.
Flags: needinfo?(giles)
Huh. The new code doesn't run anything at startup. Could this just be from loading the additional XUL.dll code?

Note this code is only built on Nightly, not riding the trains, so it won't affect Firefox 56 release.

I'll look for static initializers, in the 3rd party code. Otherwise I'm out of ideas.
Assignee: nobody → giles
Flags: needinfo?(giles)
:cpearce confirmed this is just because of the additional code in XUL. The only resolution to that is to switch to a separate library for the new code and load it lazily. We'd like to do that for a lot of things, but it needs some infrastructure support, so I'm closing this for now.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.