Closed Bug 1376514 Opened 2 years ago Closed 2 years ago

Crashes with mcbrwctl.dll (McAfee SiteAdvisor) increasing in 55

Categories

(External Software Affecting Firefox :: Other, defect)

All
Windows
defect
Not set

Tracking

(firefox55+ wontfix, firefox56 wontfix, firefox57 disabled)

RESOLVED WORKSFORME
Tracking Status
firefox55 + wontfix
firefox56 --- wontfix
firefox57 --- disabled

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: regression)

Crash Data

Attachments

(1 file)

crashes with modules from the mcafee site/webadvisor addon are increasing in the 55 cycle - they account for over 1.5% of browser crashes atm (while the were just 0.15% in 54.0b).

should we look into reaching out to mcafee or consider blocklisting the addon or the dll?
n-i to myself to write to mcafee and ask PI for help
Flags: needinfo?(lhenry)
Emailed Konstantin and Pavan who worked on the last McAfee issue a few months ago.
Flags: needinfo?(lhenry)
Crash Signature: mcbrwctl.dll@0x19487] → mcbrwctl.dll@0x19487] [@ mcbrwctl.dll@0x11914] [@ mcbrwctl.dll@0x1aa99]
The fix for this will be in the new version of SiteAdvisor, 4.0.6. 

Can we tell if there's a specific version correlated with the crash? The signatures I looked at didn't have correlation data.
Pete, should we block the busted versions -- they seem pretty crashy.
Flags: needinfo?(pdolanjski)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #3)
> The fix for this will be in the new version of SiteAdvisor, 4.0.6. 

Liz, do we know when that'll be available?

(In reply to Mike Taylor [:miketaylr] (55 Regression Engineering Owner) from comment #4)
> Pete, should we block the busted versions -- they seem pretty crashy.

Let's get the ETA on the update and then inform McAfee that we're going to block those older versions before we proceed, but yes.
Flags: needinfo?(pdolanjski) → needinfo?(lhenry)
I'll cc you on the email thread. The older versions are 4.0.6.145 and below.
Flags: needinfo?(lhenry)
according to mcafee the extension version number wasn't bumped with this update - so if we'd decide to blocklist we could only use the dll blocklisting mechanism to target 4.0.6.145 and below.
this would be a patch if we decide to add the crashy webadvisor modules onto the blocklist.

i've briefly tested it and it's successful in blocking those dlls out of the firefox process. 
this is also rendering the addon unusable though, its toolbar button is gone and it's no longer manipulating sites' content, though it is still showing up as enabled which might be confusing to affected users. there's also no immediate remedy as according to mcafee the update to version 4.0.6.146 is rolled out at a throttled rate at the moment & is not yet available through the common download page for the product.
Comment on attachment 8888530 [details] [diff] [review]
bug1376514_blocklisting.patch

hi, could you chime in if we should take that patch? afaik the addon is quite popular (nearly 3% of users on release have it), so it's probably a weighing act of one sort of breakage against another (see comment #8).
i don't have access to the telemetry data showing what's the share of the affected dlls versus the fixed version 4.0.6.146 currently...
Attachment #8888530 - Flags: review?(pdolanjski)
the crash rate seems to be on the decline since mcafee started to push out the fix to a broader base, so we may be lucky here and not necessarily depend on the blocklist entry to mitigate most of it.

if any affected user ends up reading this: you should try uninstalling webadvisor through the system control panel & reinstall the latest version from https://home.mcafee.com/root/landingpage.aspx?lpname=get-it-now
:philip -- should we consider this issue resolved at this point?
Flags: needinfo?(madperson)
the issue is still around as a mid-volume crash (230 crash reports per day with mcbrwctl.dll in the signature), but at least it should be "fixed" in 57 once the mcafee legacy extension is no longer able to run in firefox and inject this kind of instability.
Flags: needinfo?(madperson)
Let's reopen if 57+ becomes susceptible somehow...
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.