embedded image is thrown away if one of the recipients is not listed as being able to receive html

RESOLVED DUPLICATE of bug 180997

Status

--
major
RESOLVED DUPLICATE of bug 180997
17 years ago
10 years ago

People

(Reporter: esther, Assigned: bugzilla)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.0.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using build 200204112 branch build and having Format preference set to Convert
message to plain text (some formatting may be lost) if you send a mail message
with and embedded imaage to several recipients with only 1 of these recipients
with a domain that is not listed anywhere as being able to recieve HTML the
embedded image is stripped from the message being sent resulting in no one
getting the image.  Note: send the same message with the same preference
settings but remove that recipient, the message is sent and the recipients get
the embedded image.
I know the preference is set to Convert to plain text, however in the html
domain section it states: "When you send a message to an address with one of the
domain names listed below, Mail automatically sends the message in the correct
format." This statement works only if all the domains of the recipients are on
the list to recieve html.  

1. Launch app- have Mail Formating preference set to Convert to plain text
2. Launch mail and send a message with and embedded image to 3 recipients making
sure the domain of one of the recipients is not listed in the html domain
section of the Formating preference and has Unknown as the option chosen for the
Address Book card.
3. Get the message for each recipient.
Result:  None of the recipients have the embedded image.
Expected:  The 2 recipients capable of receiving html should have the image in
the message.  I say this because if I only send to the 2 recipients who can
receive html, they get the html regardless of the preference to convert to plain
text.  It's not until the 3rd recipient is added that the embedded image is
stripped from the message.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 1

15 years ago
xref bug 187064.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 180997 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.