[a11y] Big blue buttons on all tabs must have a better focused state styling.

VERIFIED FIXED in Firefox 56

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: yzen, Assigned: yzen)

Tracking

({access})

unspecified
Firefox 56
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 verified, firefox58 verified)

Details

(Whiteboard: [photon-onboarding])

Attachments

(5 attachments)

(Assignee)

Description

2 years ago
Right now only the text has a faintly dotted outline when the button is in focus. We should have something more pronounced, similar to the main Firefox UI, or about:preferences focused button layout.
according to the discussion with Photon onboarding PM/UX, change to P3
Priority: -- → P3
Whiteboard: [photon-onboarding][triage] → [photon-onboarding]
(Assignee)

Updated

2 years ago
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Added button focus styling , it also works well in high contrast.
Attachment #8889548 - Flags: ui-review?(mverdi)
Attachment #8889548 - Flags: review?(dtownsend)
(Assignee)

Comment 3

2 years ago
Posted image Before
(Assignee)

Comment 4

2 years ago
Posted image Before High Contrast
(Assignee)

Comment 5

2 years ago
Posted image After
(Assignee)

Comment 6

2 years ago
Posted image After High Contrast
Comment on attachment 8889548 [details] [diff] [review]
1377285 button focus styling.

That's awesome - thank you!
Attachment #8889548 - Flags: ui-review?(mverdi) → ui-review+
Attachment #8889548 - Flags: review?(dtownsend) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 8

2 years ago
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ae7f1e8f2b35
better focus styling for onboarding-tour action buttons. r=mossop
Keywords: checkin-needed
(Assignee)

Updated

2 years ago
Blocks: 1377298

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ae7f1e8f2b35
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced this bug with nightly 56.0a1 (2017-06-29) on Linux Mint (64 Bit).

The bug's fix is now verified on Latest Nightly 56.0a1

Build ID 	20170803100352
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170802]
I can verify this issue has been fixed
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

2 years ago
Comment on attachment 8889548 [details] [diff] [review]
1377285 button focus styling.


This is one of several bugs that make onboarding accessible to keyboard and screen reader users.
[Feature/Bug causing the regression]: None
[User impact if declined]: Users who use accessibility services or keyboard would not be able to use onboarding.
[Is this code covered by automated tests?]: No, css changes only
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Onboarding action buttons should have a focus styling that is well visible - blue outline.
[List of other uplifts needed for the feature/fix]: not for this bug, but all onboarding accessibility bugs are listed in bug 1377300
[Is the change risky?]: No
[Why is the change risky/not risky?]: Only affects users that use keyboard
[String changes made/needed]: None
Attachment #8889548 - Flags: approval-mozilla-beta?
It looks like this fix landed on 56 already back in July.
Attachment #8889548 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
I can confirm the styling is as specified in comment 12.
I verified using Fx 56.0b8, on Windows 10 x64, mac OS X 10.12.6 and Ubuntu 14.04 LTS.
Flags: qe-verify+
QA Contact: jwilliams
I have verified that this issue works as expected per comment 12 on Win 10 x64, Win 7 x86, Mac 10.13, & Ubuntu 16.04 x32 with Firefox 58.
You need to log in before you can comment on or make changes to this bug.