WebRTC: There is no "a=group:BUNDLE" in SDP when create peer connection/offer with audio only

RESOLVED DUPLICATE of bug 1366581

Status

()

RESOLVED DUPLICATE of bug 1366581
2 years ago
2 years ago

People

(Reporter: igor, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8882542 [details]
ff_bundle_group_issue.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

1. Open WebRTC peer connection, audio only example https://webrtc.github.io/samples/src/content/peerconnection/audio/
2. Press on 'Call' button and establish audio connection



Actual results:

Look at console logs for local SDP ('Offer from pc1' line).
There is no "a=group:BUNDLE" line in SDP.

There are no any visible issues with this example.
But when we use WebRTC stack between FF and Android and setup audio only call then Android side throws an exception:

"max-bundle specified without BUNDLE specified"
"Failed to set remote offer sdp: Failed to create channels"

this is where it comes from
https://chromium.googlesource.com/external/webrtc/+/master/webrtc/pc/webrtcsession.cc#1714

and nothing works


Expected results:

It should be there a "a=group:BUNDLE" line in SDP.

Other facts:
1. there is a line "a=group:BUNDLE" in SDP when we use video+audio call
2. there is a line "a=group:BUNDLE" in SDP when we use audio only call and Chrome
Component: Untriaged → WebRTC: Signaling
Product: Firefox → Core
This has already been fixed in Firefox 55.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1366581
You need to log in before you can comment on or make changes to this bug.