Port bug 492329 to SM: The error message for an expired newsgroup article is not displayed.

RESOLVED FIXED in seamonkey2.53

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Alfred Peters, Assigned: frg)

Tracking

Trunk
seamonkey2.53

SeaMonkey Tracking Flags

(seamonkey2.53 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
Look at an expired article of a newsgroup.

SM displays an (incorrect) error message:
| Invalid Address
| 
| The URL is not valid and cannot be loaded.
| 
| The provided address is not in a recognized format. Please check the location bar for mistakes and try again.

According to DOM-Inspector is the URL: "about:newserror?r=no%20such%20article%20number%20in%20this%20group&m=oj697r.cc0.1@gammasigma.xy&k=113&f=news://ham.gammasigma.xy/de.mein.test4"

The message should be displayed as in Thunderbird:
| Article not found
| The newsgroup server reports that it can't find the article.
|     Newsgroup server responded: no such article number in this group
|     Perhaps the article has expired?
|     Try searching for article: <oj697r.cc0.1@gammasigma.xy> (113)
(Reporter)

Comment 1

a year ago
It's a regression from Bug 492329
Blocks: 492329

Comment 2

a year ago
Hmm, sorry, looks like I/we broke something in SM:
https://hg.mozilla.org/comm-central/rev/f3926c01ebe5f4796bfbe696101c7b13e4b44e88

The original patch was from Jim and Neil reviewed it. There are parts in mail/, mailnews/ and we even added bits to suite/. Looks like the mail/ parts need porting.
Summary: The error message for an expired newsgroup article is not displayed. → Port bug 492329 to SM: The error message for an expired newsgroup article is not displayed.
(Assignee)

Comment 4

a year ago
Created attachment 8882847 [details] [diff] [review]
1377659-newserror.patch

Well you usually fix more than you break so its ok with me :)

Patch does not work yet. Error in nsAbout.js line 51:

> NS_ERROR_MALFORMED_URI: Component returned failure code: 0x804b000a >(NS_ERROR_MALFORMED_URI) [nsIIOService2.newURI]


I hate regular expressions!
(Assignee)

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #4)
> > NS_ERROR_MALFORMED_URI: Component returned failure code: 0x804b000a >(NS_ERROR_MALFORMED_URI) [nsIIOService2.newURI]
Hmm, we open that with nsIWebNavigation:
https://hg.mozilla.org/comm-central/rev/f3926c01ebe5f4796bfbe696101c7b13e4b44e88#l8.80

What's the URI that fails and what does this have to do with regular expressions??
(Assignee)

Comment 6

a year ago
>> What's the URI that fails and what does this have to do with regular expressions??

about:newserror without parameters. Need to check it out tomorrow if the getmodule returns garbage.

Just entering chrome://messenger/content/newsError.xhtml works.
(Assignee)

Comment 7

a year ago
Created attachment 8882866 [details] [diff] [review]
1377659-newserror.patch

This should work. The previous version had a capital E in newserror.
Assignee: nobody → frgrahl
Attachment #8882847 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8882866 - Flags: review?(rsx11m.pub)
(Assignee)

Updated

a year ago
status-seamonkey2.53: --- → affected

Comment 8

a year ago
I'm glad it's not a big patch, sorry again for the breakage.
(Assignee)

Comment 9

a year ago
No problem. I just need to find an expired article to actually test it. But about:newserror shows up ok now.

Comment 10

a year ago
m.t.multimedia, from Stanimir Stamenkov, 30/10/2016. Somehow the "remove expired messages" doesn't work, but the message and button show.
(Reporter)

Comment 11

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #7)
> Created attachment 8882866 [details] [diff] [review]
> 1377659-newserror.patch
> 
> This should work.

Yes, works great for me.
(Assignee)

Comment 12

a year ago
> Yes, works great for me.

Confirmed. 

Is the non working button another bug or SeaMonkey specific?
(Reporter)

Comment 13

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #9)
> No problem. I just need to find an expired article to actually test it. But
> about:newserror shows up ok now.

The easiest way is:

1. Post an article with another reader to a test group.
2. Fetch that group into SM.
3. Chancel the article.
4. Restart SM and fetch the group again.
(Reporter)

Comment 14

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #12)

> Is the non working button another bug or SeaMonkey specific?

For me the button works.

Comment 15

a year ago
(In reply to Frank-Rainer Grahl (:frg) from comment #12)
> Is the non working button another bug or SeaMonkey specific?
It works, just not on Stanimir Stamenkov, 30/10/2016. No idea why.
(Reporter)

Comment 16

a year ago
(In reply to Jorg K (GMT+2) from comment #15)
[m.t.multimedia]
> It works, just not on Stanimir Stamenkov, 30/10/2016. No idea why.

Yes also with TB and with a new subscription. In this case, the message should not occur at all.

The riddle Solution: The database of the server is corrupt.
"XOVER 3452" returns the data from the record.
But "ARTICLE 3452" says "430 no such article"

As long as the XOVER supplies the data, the message will also appear.

No error in SM / TB.
(Assignee)

Comment 17

a year ago
> Yes also with TB and with a new subscription. In this case, the message should not occur at all.

Thanks for the explanation. Thought so. Wondered why the article apperaed when I just subscribed.

Comment 18

a year ago
Comment on attachment 8882866 [details] [diff] [review]
1377659-newserror.patch

Looks like a straight-forward port for the new about: page.

I'm wondering if this should have "|HIDE" as well, like certerrorFlags?
No need to list this in about:about as it's de-facto an error message.

We have to consider TRUSTED content due to the button?
Attachment #8882866 - Flags: review?(rsx11m.pub) → review+
(Assignee)

Comment 19

a year ago
Pushed with HIDE as suggested. Makes sense.

https://hg.mozilla.org/comm-central/rev/961c601f9062233a1e939610ee77e4de5fe7ad48

UNTRUSTED does not work. If it were just for the button it should probably be set but the message id is not displayed without it so chrome access is needed.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-seamonkey2.53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.53
(Assignee)

Comment 20

a year ago
Goofed and forgot the set r= Thought it wasn't possible to push without r= or rs=

Backout and repush:
https://hg.mozilla.org/comm-central/rev/ce98c4de85458c462178baf3c5d6c8080d4a7a61
https://hg.mozilla.org/comm-central/rev/dcda0c70e843eef495be304cd28c358c8b11b162
You need to log in before you can comment on or make changes to this bug.