Forget panel cuts content

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jlg.l10n.es, Assigned: Gijs)

Tracking

56 Branch
Firefox 57
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 1369729])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170630030203

Steps to reproduce:

Nightly 56.0a1 (2017-06-30) (64-bit) es-ES, Windows 10
I customized the menu adding the FORGET option. After browsing for a while I pressed the "More tools..."  (Más herramientas...) and the Forget option.


Actual results:

The contents are not fully displayed, the button for forgetting is cut and only the top part is shown.

Screenshot: https://screenshots.firefox.com/R5k2aqivuElPwqla/null


Expected results:

I expect to see the whole button, as in previous versions of Firefox
Component: Untriaged → Menus

Updated

a year ago
Blocks: 1069300
Component: Menus → Toolbars and Customization
Summary: Forget menu cuts content → Forget panel cuts content
Blocks: 1369729
No longer blocks: 1069300
The patch in bug 1369729 should fix this. It's waiting on some work to automated tests.
No longer blocks: 1369729
Depends on: 1369729
This works for me on today's nightly, which has the fix for bug 1369729. Can you confirm if this is fixed for you, too?
Flags: needinfo?(jlg.l10n.es)
(Reporter)

Comment 3

a year ago
It's working for me too, I can see all the panel contents
Thanks!
Flags: needinfo?(jlg.l10n.es)
Thanks!

Paolo, technically this issue happens on 55 as well if you empty the hamburger panel out of most things, and do add the forget/panic button to it. This seems enough of an edgecase (moreso than with Photon where the panel starts out being empty) that I'm not convinced we need to fix it via uplift, but I'm wondering if there's other reasons to uplift the fix from bug 1369729 to 55 that I'm missing?
Assignee: nobody → gijskruitbosch+bugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(paolo.mozmail)
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1369729]
Target Milestone: --- → Firefox 57

Comment 5

a year ago
I'm not aware of other bugs the would affect the non-Photon version, on the other hand uplifting this change might mean that if we discover other issues later, they will be easier to uplift because the code is more similar between Beta and Nightly.
Flags: needinfo?(paolo.mozmail)
You need to log in before you can comment on or make changes to this bug.