Closed Bug 1377879 Opened 3 years ago Closed 2 years ago

Highlighters can remain behind if Fx is slowly resized

Categories

(DevTools :: Inspector, defect, P3, minor)

53 Branch
defect

Tracking

(firefox-esr52 unaffected, firefox54 wontfix, firefox55 wontfix, firefox56 wontfix, firefox57 fixed)

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- wontfix
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- fixed

People

(Reporter: bogdan_maris, Assigned: zer0)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
- Firefox 54.0.1
- Firefox 55 beta 6
- latest Nightly 56.0a1

[Affected platforms]:
- macOS 10.12
- Ubuntu 16.04 64bit
- Windows 10 64bit

[Steps to reproduce]:
1. Start Firefox
2. Visit a webpage that uses CSS Grid
(eg: https://www.mozilla.org/en-US/developer/css-grid/)
3. Enable a grid overlay from Inspector/Layout or Rules
4. Slowly resize Firefox window

[Expected result]:
- Grid overlay moves along with its boxes.

[Actual result]:
- Grid overlay remains behind while slowly resizing.

[Regression range]:
- This is a regression, not recent though. Based on mozregression I get the following pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0a7831d838f793a263456df62f95a615472a7f95&tochange=a9ec72f82299250e6023988e238931bbca0ef7fa

Most likely the culprit is:
07de05d8060c	Matteo Ferretti — Bug 1312103 - Avoid scrolling latency on highlighters given by APZ; r=pbro

[Additional notes]:
- Screencast showing the issue attached.
- The overlay comes back to normal if resized to much or if I hover boxes from Outline of the selected grid (From Inspector/Layout)
Flags: needinfo?(zer0)
Gah, screencast is too big to upload it directly to bugzilla, I had to upload it to dropbox: https://www.dropbox.com/s/vizij2jgh9eaq33/grid%20overlay%20remains%20behind.mov?dl=0
Not a recent regression. Mark 54 won't fix. Let's see if we can fix it in 55.
I think this is a minor one because you have to resize slowly for it to happen, and there are many cases that make it snap back into place (like, resizing the window again, or hovering over the grid outline in the layout panel, etc.)
So I don't think this should block shipping the layout panel with 56. Would be nice to still fix it though.
Priority: -- → P3
Adjusted the subject since the issue can be reproduced in every highlighter is based on `auto-refresh.js` (most of ours are).
Flags: needinfo?(zer0)
Summary: Grid overlay remains behind if Fx is slowly resized → Highlighters can remain behind if Fx is slowly resized
Comment on attachment 8906861 [details]
Bug 1377879 - adjusted `areValuesDifferent` calculation for quads;

https://reviewboard.mozilla.org/r/178588/#review183660
Attachment #8906861 - Flags: review?(pbrosset) → review+
Pushed by mferretti@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3867d0df5caf
adjusted `areValuesDifferent` calculation for quads; r=pbro
https://hg.mozilla.org/mozilla-central/rev/3867d0df5caf
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Seems a bit of a corner case for uplift this late in 56, but please request approval ASAP if you think we should fix this there.
Assignee: nobody → zer0
Flags: needinfo?(zer0)
Version: Trunk → 53 Branch
We're already creating RC builds for 56. Not going to be taking this bug at this point.
Flags: needinfo?(zer0)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.