WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 2989, uid: 1234 }, _phantom: PhantomData } has an invalid value.

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: kats, Assigned: pchang)

Tracking

Other Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(1 attachment)

Seen this getting spammed in a bunch of intermittent failure logs:

WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 2989, uid: 1234 }, _phantom: PhantomData } has an invalid value.

https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=110316321&lineNumber=39747
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=110740104&lineNumber=40599
Still seeing this as of August 10 even on passing runs.
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
(Assignee)

Comment 2

2 years ago
I also saw these log with debug build recently. I will work on this.
Assignee: nobody → howareyou322
Status: NEW → ASSIGNED
Priority: P2 → P1
Did you make any progress on this? I suspect this output is contributing to talos failures because the logs overflow. So fixing it would be quite useful.
Flags: needinfo?(howareyou322)
(Assignee)

Comment 4

2 years ago
I saw two different kinds of warning logs in the following.
For the 'zero' id one, we could filter it by checking valid animation id in [1].
It could reduce lots of warning.

For the non-zero id cases, I guest compositor reject the animations request but we still push this animation request on the content side.

[Logs]
WARN:webrender::scene: Property binding PropertyBindingId { namespace: IdNamespace(0), uid: 0 } has an invalid value about opacity. value 1
WARN:webrender::scene: Property binding PropertyBindingId { namespace: IdNamespace(51489), uid: 1 } has an invalid value about opacity. value 1

[1]http://searchfox.org/mozilla-central/rev/298033405057ca7aa5099153797467eceeaa08b5/gfx/webrender_bindings/src/bindings.rs#1175
(In reply to Peter Chang[:pchang] from comment #4)
> I saw two different kinds of warning logs in the following.
> For the 'zero' id one, we could filter it by checking valid animation id in
> [1].
> It could reduce lots of warning.

This makes sense, and would help a lot. Are you going to write a patch for this, or do you want me to?
(Assignee)

Comment 6

2 years ago
I just submit a try to see we can pass talos or not with layers-free enabled.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3610ecf157ef531ec9487416fd345df75e44ae58
Flags: needinfo?(howareyou322)
Comment hidden (mozreview-request)
(Reporter)

Comment 8

2 years ago
mozreview-review
Comment on attachment 8914311 [details]
Bug 1377894 - Create the new opacity animations only when the animation id is valid,

https://reviewboard.mozilla.org/r/185598/#review190572
Attachment #8914311 - Flags: review?(bugmail) → review+
Looks like it didn't help with the talos :/ Still worth landing though. If we can get to the bottom of the other source of the output that would be good as well.
(Assignee)

Comment 10

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #8)
> Comment on attachment 8914311 [details]
> Bug 1377894 - Create the new opacity animations only when the animation id
> is valid,
> 
> https://reviewboard.mozilla.org/r/185598/#review190572

This one only fixed the warning log with zero id, I will keep working on the non-zero id.
(Assignee)

Updated

2 years ago
Keywords: leave-open

Comment 11

2 years ago
Pushed by pchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7a2d0f49c4c
Create the new opacity animations only when the animation id is valid, r=kats
(Assignee)

Comment 13

a year ago
I just found the cause for the warning log with non-zero id but I had problem to sumbit the patch via mozreview. So I will clone this bug for the follow-up work.
Summary: WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 2989, uid: 1234 }, _phantom: PhantomData } has an invalid value. → WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 0, uid: 0 }, _phantom: PhantomData } has an invalid value.
(Assignee)

Comment 14

a year ago
I shouldn't change the title.
Summary: WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 0, uid: 0 }, _phantom: PhantomData } has an invalid value. → WARN:webrender::scene: Property binding PropertyBindingKey { id: PropertyBindingId { namespace: 2989, uid: 1234 }, _phantom: PhantomData } has an invalid value.
(Assignee)

Updated

a year ago
Blocks: 1410334
(Assignee)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.