The first item in the fixed-overflow panel has too much margin-top

RESOLVED DUPLICATE of bug 1354086

Status

()

RESOLVED DUPLICATE of bug 1354086
2 years ago
a year ago

People

(Reporter: jaws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The first item in the fixed-overflow panel has too much margin-top. We should only be setting margin-top for items that are not the first-child. This rule here is the cause of the problem, http://searchfox.org/mozilla-central/rev/5bb6dfcb3355a912c20383578bc435c1d4ecf575/browser/themes/shared/customizableui/panelUI.inc.css#1382

It is currently matching on the first selector, `panelview .toolbarbutton-1`.

Updated

2 years ago
Blocks: 1352692
No longer blocks: 1349210
Depends on: 1354086

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1354086
Whiteboard: [photon-structure][triage]

Comment 3

2 years ago
Eh, meant to comment here when duping, but for completeness' sake: I duped this because ultimately, for the photon styling we want to get rid of the margin completely, and so updating the selector only to exclude the top item isn't really that useful, and it seems to me verifying the new styling will also verify this bug, so keeping a separate bug open doesn't seem worth it.
No longer blocks: 1352692
No longer depends on: 1354086
You need to log in before you can comment on or make changes to this bug.