Add Search Bookmarks, Search History to browser search menu

RESOLVED DUPLICATE of bug 82938

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED DUPLICATE of bug 82938
16 years ago
9 years ago

People

(Reporter: BenB, Assigned: jglick)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Add Search Bookmarks, Search History to browser search menu

Currently, you have to open the Bookmarks manager and open Tools something menu
item there. Similar for History. Both functions are much more relevant and more
often needed in the browser than e.g. Search Messages.

Comment 1

16 years ago
-> jglick
Assignee: blaker → jglick

Comment 2

16 years ago
qa --> claudius@netscape.com
QA Contact: paw → claudius
(Assignee)

Comment 3

16 years ago
If we added these items to the Tools menu, I would recommend opening the 
appropriate search dialog as well as its parent window. For example, if the user 
selects "Search Bookmarks", the Bookmarks window would open with the Bookmarks 
Search dialog on top of it.
(Reporter)

Comment 4

16 years ago
That would annoy me, and I don't see a reason to do that. The bookmarks window
is the bookmarks *manager*, a tool to *modify* bookmarks. I can *access*
bookmarks using the bookmarks menu, without the bookmarks manager. Searching
bookmarks is also a way to *access* bookmarks, usualy when I don't remember the
folder or name. most if the time, I don't want to modify bookmarks at the same
time, and opening the bookmarks window would only force me to close another
window each time.

Comment 5

16 years ago
Currently, Search Bookmarks displays the search results in a separate new
window, so I'm not sure why it would open the bookmark manager first.  I think
what is missing here is a lightweight Find in Bookmarks feature, as in Nav 4.x
and everywhere else, that selects the results in place.  Currently, there is no
easy way to locate related bookmarks that are filed together, since you can't
use search to find them in context.
(Assignee)

Comment 6

16 years ago
>Currently, Search Bookmarks displays the search results in a separate new
>window, so I'm not sure why it would open the bookmark manager first.

OK. Sorry. I was under the impression that it worked like 4.x, in which the 
parent window is used for results. But I see now that it actually opens a whole 
new search results window. Scatch my previous comment. The Bookmarks or History 
search would open by itself and display the Bookmark Search Results or History 
Search Results windows as appropriate.

One thing i did notice though, is that all the same functionality that is 
available in the Bookmarks window is available also in the Search Results - 
Bookmarks window. I was able to create a new folder and a new sepatator from the 
Seach results window. But the new folder and separator didn't appear in the 
search results window, they appeared in the Bookmarks window. That is sorta odd. 
So, we'd prob want to limit the functionality available in the search result 
windows.

Comment 7

16 years ago
i think quick search in bookmarks/history (ala mail) would be perfect :)

Comment 8

16 years ago
*** Bug 162542 has been marked as a duplicate of this bug. ***
fwiw, specific bm qs: bug 162542

Comment 10

16 years ago

*** This bug has been marked as a duplicate of 82938 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.