Middle click on Bookmark and History closed tab entry does not open it in new tab

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: alice0775, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {regression})

56 Branch
Firefox 57
Unspecified
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 disabled, firefox57 verified)

Details

(Whiteboard: [photon-structure])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Reproducible : always

Steps To Reproduce:
1. Open Hamburger menu
2-1 Open Library > Bookmarks. And middle mouse click on a Bookmark entry.
2-2 Open Library > History. And middle mouse click on a closed tab entry.

Actual Results:
Nothing opened

Expected Results:
The entry should be open in new tab
(Assignee)

Comment 1

a year ago
(In reply to Alice0775 White from comment #0)
> Reproducible : always
> 
> Steps To Reproduce:
> 1. Open Hamburger menu
> 2-1 Open Library > Bookmarks. And middle mouse click on a Bookmark entry.

I can reproduce this. Note that modifier-click (ie ctrl/cmd) *does* work.

> 2-2 Open Library > History. And middle mouse click on a closed tab entry.

but not this. This breaking would be confusing anyway, because it's the same subview as we show for the history button. Can you reproduce this second bit on a clean profile? Anything else that might explain the difference? Can you maybe find a regression window, which might help narrow this down?
Blocks: 1354159
Flags: needinfo?(alice0775)
Whiteboard: [photon-structure] → [photon-structure][triage]
(Assignee)

Comment 2

a year ago
(In reply to :Gijs from comment #1)
> > 2-2 Open Library > History. And middle mouse click on a closed tab entry.
> 
> but not this.

Is it possible you're clicking a 'closed window' entry instead? I can reproduce that not doing anything with middle clicks, but that seems like it isn't a regression - I can reproduce on beta with the old history button.
(Reporter)

Comment 3

a year ago
> 2-2 Open Library > History. And middle mouse click on a closed tab entry.

Correct STR is as follows

2-2-0 Close 3 tabs for example
2-2-1 Open Library > History
2-2-2 Middle mouse click on a 1st closed tab entry.
      --- observe, it open in new tab as expected
      Middle mouse click on a 2nd closed tab entry.
      --- observe, It seems 3rd one opened in new tab --- BUG
      Middle mouse click on a 3rd closed tab entry.
      --- observe, nothing opened --- BUG


Actual Results:
1st one is properly open in newtab.
However, 2nd, 3rd and ...
Sometimes open wrong url in newtab
Sometimes not open anything

Expected Results:
Should open them in newtab properly
Flags: needinfo?(alice0775)
Flags: qe-verify+
Priority: -- → P2
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [photon-structure]
Since the photon team triaged this I'm marking the bug fix-optional for 56. Happy to take a patch, but the platform team doesn't need to re-triage.
status-firefox56: affected → fix-optional
(Assignee)

Updated

a year ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 57.1 - Aug 15
Priority: P2 → P1
Comment hidden (mozreview-request)

Comment 6

a year ago
mozreview-review
Comment on attachment 8895508 [details]
Bug 1377967 - make middle clicking history, bookmarks and closed tabs items work correctly,

https://reviewboard.mozilla.org/r/166702/#review172260

Nice!
Attachment #8895508 - Flags: review?(mdeboer) → review+

Comment 7

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e4d1389a96ca
make middle clicking history, bookmarks and closed tabs items work correctly, r=mikedeboer
Comment hidden (mozreview-request)

Comment 10

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a6a9fbaf06ad
make middle clicking history, bookmarks and closed tabs items work correctly, r=mikedeboer
(Assignee)

Comment 11

a year ago
Re-landed after relanding the other bug without the test change.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 12

a year ago
Backout by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/2948b2ab68a1
Backed out changeset e4d1389a96ca because it blocks the backout of bug 1388753. r=backout
Comment hidden (mozreview-request)

Comment 14

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/52e5d83fadfa
make middle clicking history, bookmarks and closed tabs items work correctly, r=mikedeboer

Comment 15

a year ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/64f5e3f40f0e
make middle clicking history, bookmarks and closed tabs items work correctly, r=mikedeboer a=reland stuff lost during last merge
https://hg.mozilla.org/mozilla-central/rev/a6a9fbaf06ad
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Please request Beta approval on this when you get a chance.
status-firefox-esr52: --- → unaffected
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 20

a year ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #19)
> Please request Beta approval on this when you get a chance.

Why? Beta isn't affected, is it? It doesn't have a library button, and AIUI everything else works correctly there.
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(ryanvm)
Bah, missed the Photon part :)
status-firefox56: fix-optional → disabled
Flags: needinfo?(ryanvm)
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.