[Form Autofill] Provide a mechanism to undo all of the form autofill changes

RESOLVED DUPLICATE of bug 1404768

Status

()

Toolkit
Form Manager
P3
normal
RESOLVED DUPLICATE of bug 1404768
a year ago
8 months ago

People

(Reporter: B.J. Herbison, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [form autofill:V2])

(Reporter)

Description

a year ago
It's easy to incorrectly click and get the wrong form profile, but hard to undo the error.

Steps to reproduce:
1. Visit a page with a form.
2. Click in a form field and select the wrong profile.
3. Press control-Z.

Expected:
* All of the form autofill changes are reverted.

Actual:
* Only changes in the current input element are reverted.

(An alternate approach would be something else to click to revert all the changes, as long as it is discoverable. This might tie in with bug 990193.)
This is part of version 2 scope.
Priority: -- → P3
Whiteboard: [form autofill:V2]
Blocks: 1404768
(Reporter)

Comment 3

9 months ago
Clarifications for the spec update:

What does "click one of the form field again" mean?
1) Any field in the form.
2) Any field in the form potentially eligible to be auto filled.
3) Any field in the form actually filled by the form fill action.

What does "clear the form" mean?
A) Clear all the input fields set by the form fill action.
B) Clear all the input fields set by the form fill action which have not been subsequently modified.
C) Totally reset the form.

I would prefer option B. If you choose option A or B I think the action should be renamed.

Comment 4

9 months ago
(In reply to B.J. Herbison from comment #3)
> Clarifications for the spec update:
> 
> What does "click one of the form field again" mean?
> 1) Any field in the form.
> 2) Any field in the form potentially eligible to be auto filled.
> 3) Any field in the form actually filled by the form fill action.
> 
> What does "clear the form" mean?
> A) Clear all the input fields set by the form fill action.
> B) Clear all the input fields set by the form fill action which have not
> been subsequently modified.
> C) Totally reset the form.
> 

Thanks for raising the question :D

After discussed with Juwei, I think we'll go (3) + (B) and essentially all the behavior would be like as what Chromium does at the present stage.

> I would prefer option B. If you choose option A or B I think the action
> should be renamed.
Chromium is using the same wording. Not sure but it feels kind of straightforward for me to expect that the button clears only the filled ones if I know the popup comes from clicking on filled field.
(Reporter)

Comment 5

8 months ago
Thank you for the clarification. The spec update should be updated with the decision.
I guess this can be duped to bug 1404768 now… (that could have probably been implemented here in the first place)
No longer blocks: 1404768
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1404768
You need to log in before you can comment on or make changes to this bug.