about:home is asking for permissions

RESOLVED DUPLICATE of bug 1395820

Status

()

Firefox
Activity Streams: Newtab
RESOLVED DUPLICATE of bug 1395820
8 months ago
4 months ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Created attachment 8883434 [details]
Screen Shot 2017-07-04 at 6.31.35 PM.png

I'm on the July 2nd Nightly. I just opened about:home to check something, and got a storage permission prompt. Not sure what's doing it (and I didn't get it again on other loads of about:home). Snippet?

We shouldn't be showing a prompt for built-in pages (i.e. either we need to whitelist / special-case it, not not ask in the first place).

Updated

8 months ago
Component: Untriaged → General
status-firefox57: affected → wontfix
Component: General → Site Identity and Permission Panels
You typed about:Home (note the capitalization), which makes some internal whitelist not match. We already had bug 1395820 about this and it was transformed to deal with Activity Stream instead, since that's the new about:home?

I'm duping this bug, though we should be aware that a solution to bug 1395820 might not necessarily solve this for the old about:home as well. Not sure if we care.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Component: Site Identity and Permission Panels → Activity Streams: Newtab
Resolution: --- → DUPLICATE
Duplicate of bug: 1395820
You need to log in before you can comment on or make changes to this bug.