stylo: Panic with "Resolving style on element without current styles with lazy computation forbidden"

RESOLVED DUPLICATE of bug 1371450

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1371450
4 months ago
4 months ago

People

(Reporter: xidorn, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

When I tried to reproduce bug 1378064, it hits the debug_assert in my local debug build:
> thread '<unnamed>' panicked at 'Resolving style on element without current styles with lazy computation forbidden.', stylo\servo\ports\geckolib\glue.rs:2709
> stack backtrace:
>    0: std::sys_common::backtrace::_print
>              at C:\projects\rust\src\libstd\sys_common\backtrace.rs:94
>    1: std::panicking::default_hook::{{closure}}
>              at C:\projects\rust\src\libstd\panicking.rs:354
>    2: std::panicking::default_hook
>              at C:\projects\rust\src\libstd\panicking.rs:371
>    3: std::panicking::rust_panic_with_hook
>              at C:\projects\rust\src\libstd\panicking.rs:549
>    4: std::panicking::begin_panic<&str>
>              at C:\projects\rust\src\libstd\panicking.rs:511
>    5: geckoservo::glue::Servo_ResolveStyle
>              at .\servo\ports\geckolib\glue.rs:2709
>    6: mozilla::ServoStyleSet::ResolveServoStyle
>              at .\layout\style\servostyleset.cpp:1152
>    7: mozilla::ServoRestyleManager::ProcessPostTraversal
>              at .\layout\base\servorestylemanager.cpp:501

I suspect this is the real reason behind that bug, but am not sure.
The crash happens on <progress class="progressBar">, sounds like it may be related to bug 1377739 as well. Also it seems Boris mentioned similar panic in bug 1371450 comment 3.

It seems to me this may not relate to fullscreen at all. It can happen even without entering fullscreen.
Summary: stylo: Panic with "Resolving style on element without current styles with lazy computation forbidden" after entering fullscreen → stylo: Panic with "Resolving style on element without current styles with lazy computation forbidden"
I guess this is actually a duplicate of bug 1371450.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1371450
You need to log in before you can comment on or make changes to this bug.