360 Video plays only sound on Fennec

RESOLVED DUPLICATE of bug 1395497

Status

()

Core
Canvas: WebGL
P3
normal
RESOLVED DUPLICATE of bug 1395497
11 months ago
8 months ago

People

(Reporter: JamesCheng, Unassigned)

Tracking

56 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox57 fix-optional)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

11 months ago
If you browse https://www.facebook.com/360tube/ or any other 360 video content provider, Fennec did not handle it well...only sound can be played.

Facebook blocks Firefox so I need to add a preference by about:config
using Chrome's user agent to verify this issue.

key: general.useragent.override 
value: Mozilla/5.0 (Linux; Android 7.1.2; Pixel XL Build/NJH47B) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.125 Mobile Safari/537.36



https://www.nytimes.com/video/the-daily-360

This website uses HLS with 360 video, the symptom is the same as above.

Desktop browser can play it but the performance is not good.
(Reporter)

Comment 1

11 months ago
Hi Blake,

Could you please find a right person to triage this issue?

I think this is more like graphics side issue.

Thank you.
Flags: needinfo?(bwu)
The best way is to change the component name to GFX. :-)
tracking-fennec: --- → ?
Component: Audio/Video → Graphics, Panning and Zooming
Flags: needinfo?(bwu)
I can also repro with the nytimes video. It works on desktop but on Fennec the video remains black. The video appears to be rendered using canvas, so moving this to Canvas.
Component: Graphics, Panning and Zooming → Canvas: 2D
OS: Unspecified → Android
Product: Firefox for Android → Core
Hardware: Unspecified → ARM
Version: unspecified → 56 Branch

Updated

11 months ago
Whiteboard: [gfx-noted]

Comment 4

11 months ago
remove fennec tracking since there's nothing we can do here.
tracking-fennec: ? → ---
(Reporter)

Comment 5

11 months ago
Hi Daosheng,

You are the only one I know who knows more about this.

Is this something related to WebGL since the error involved 'webgl' keywords while playing the nytimes daily 360?

07-13 16:30:04.781 27413 27431 W GeckoConsole: [JavaScript Warning: "Error: WebGL warning: texImage2D: GetAsSourceSurface or GetDataSurface failed after blit failed for TexUnpackImage." {file: "https://static01.nyt.com/video/vhs/2.130.3-1359/libs/kaleidoscope.iife.min.js" line: 7}]

Do you know who can invest in this bug?

Please help us forward this bug to the right person to make the bug move on.

Many thanks.
Flags: needinfo?(dmu)
:jgilbert might be the right person that you are looking for, but I am not sure if Fennec support is also on his radar.
Flags: needinfo?(dmu)
(Reporter)

Comment 7

11 months ago
Thanks,

Hi jgilbert,

Would you please take a look at this bug?

Thank you.
Flags: needinfo?(jgilbert)
(Reporter)

Updated

11 months ago
Blocks: 1380813
Priority: -- → P3

Updated

9 months ago
Is this still a problem in Fennec nightly?
status-firefox57: --- → fix-optional
(Reporter)

Comment 9

9 months ago
Yes
You can try to repro it by comment 0.
Duplicate of this bug: 1380813

Comment 11

8 months ago
Hi Everyone , 

We encountered the same problem @novelab with our 360 video player.

We use the VideoTexture from threejs on firefox mobile / android , ang we got:

Error: WebGL warning: texImage2D: GetAsSourceSurface or GetDataSurface failed after blit failed for TexUnpackImage. bundle.js:3:7416

if anyone has found out, or has news about any update on that topic, let me know !!!
Component: Canvas: 2D → Canvas: WebGL
Flags: needinfo?(jgilbert)
Jeff, is the error in comment 11 pointing to something that needs fixing in threejs side, or our side?  If not our side, what direction can we give?
Flags: needinfo?(jgilbert)
(In reply to Milan Sreckovic [:milan] from comment #12)
> Jeff, is the error in comment 11 pointing to something that needs fixing in
> threejs side, or our side?  If not our side, what direction can we give?

This is probably our side, likely bug 1395497. (Does that sound right, snorp?)
Flags: needinfo?(jgilbert) → needinfo?(snorp)
Yup.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(snorp)
Resolution: --- → DUPLICATE
Duplicate of bug: 1395497
You need to log in before you can comment on or make changes to this bug.