Download file selector dialogue stops all other download tasks

VERIFIED DUPLICATE of bug 132999

Status

defect
VERIFIED DUPLICATE of bug 132999
18 years ago
15 years ago

People

(Reporter: zapyon, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

()

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

When downloading several files in a row the following occurs: Some files are
already being downloaded. You pick the next file in the list, but it takes some
time to connect to the server and then show the file selector dialogue to
specify where you want to put the file. So you switch to doing whatever you are
doing. When the file selector pops up all other download tasks are interrupted
and will not continue. This happens always in Win98. The effects can be very
annoying (and even expensive in some cases): If you don't realise there is this
dialoge open, the other downloads are never finished, but rather will they be
aborted due to timeouts. This has happened again to me when I started about 15
downloads of large files over night and forgot to [ok] the last dialogue box:
All other downloads were aborted - and some of the files were huge! Imagin this
to happen to someone with modem or ISDN connection!

I would be happy if this effect of the file selector could be removed somehow.

Kind regards

Andreas


Reproducible: Always
Steps to Reproduce:
1. Start one download
2. Click on another download link but don't answer the file selector dialogue
asking for a place (+ name) to put the file.
3. See how the first download will not continue and will be aborted due to
timeout when you eventually answer the file selector.

Actual Results:  You lose all previously started active downloads if you wait
long enough (see above). Also, other browser windows will not load anything if
you want to load a new page. But of course this is not so grave because you
realise what is going on, when the file selector is topped. But if you are
working in another application at the time ... or even away from your desk ... =(

Expected Results:  The file selector should not have affected the already
running download tasks. They should have finished fine (instead of being aborted
due to timeout).

As an after-effect the system became very unstable after I had the download
tasks aborted in the morning this time. I had to reboot Win98 to have a
(relatively ;-) stable system (I know this doesn't happen in Linux .. ;-).

I was considering calling this "A major feature is broken" because download
actually IS a major feature for many people today, but I think you are getting
so many bug reports that not each and any should be called severe, right? ;-)
Regards. Andreas

*** This bug has been marked as a duplicate of 132999 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.