Closed Bug 1379357 Opened 2 years ago Closed 2 years ago

Zoom widget label should be fixed width

Categories

(Firefox :: Toolbars and Customization, defect, P1, minor)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: alice0775, Assigned: mikedeboer)

References

(Depends on 1 open bug)

Details

(Keywords: polish, Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

It is annoying that +/- button position shifts when changing from 100% to 90% and vice versa.

Reproducible: always

Steps to reproduce:
1. Open Hamburger menu
2. When current zoom>=100%,
   Repeatedly click [-] button to zoom out, (easy to reproduce, click most left side of the button)

Actual Results:
Menu close suddenly, when zoom 100% to 90%
So, I can not zoom out with repeated clicks

Expected Results:
Menu should not close. And continuing I can zoom out with repeated clicks
  

 
Another steps to reproduce:
1. Place Zoom widget on toolbar
2. when current zoom<100%,
   Repeatedly click [+] button to zoom in, (easy to reproduce, click most left side of the button)

Actual Results:
Mouse pointer becomes on the Label of zoom level.
So, I can not zoom in with repeated clicks

Expected Results
Continuing I can zoom in with repeated clicks
Keywords: polish
Given that this predates Photon, doesn't *need* to be in 57, but I agree that this would be nice to fix.
Flags: qe-verify+
Priority: -- → P3
Whiteboard: [reserve-photon-structure]
See Also: → 1327131
QA Contact: gwimberly
Priority: P3 → P4
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Comment on attachment 8910264 [details]
Bug 1379357 - Ensure that the zoom button the app menu has a fixed width to fit the 100% label, so that the buttons next to it don't move when the label gets slimmer.

https://reviewboard.mozilla.org/r/181758/#review187094

I mean, r=me, but the bug explicitly also calls out the toolbar button item. Can we do the same thing there (when it's in the toolbar) ? Maybe as a separate cset, but still on this bug?
Attachment #8910264 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs from comment #3)
> I mean, r=me, but the bug explicitly also calls out the toolbar button item.
> Can we do the same thing there (when it's in the toolbar) ? Maybe as a
> separate cset, but still on this bug?

This is already dealt with for this control[1] when it's in a toolbar, so I don't how Alice was able to get this behavior to reproduce there.

[1] http://searchfox.org/mozilla-central/source/browser/themes/shared/customizableui/panelUI.inc.css#1626
Flags: needinfo?(alice0775)
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/736598341c09
Ensure that the zoom button the app menu has a fixed width to fit the 100% label, so that the buttons next to it don't move when the label gets slimmer. r=Gijs
(In reply to Mike de Boer [:mikedeboer] from comment #4)
> (In reply to :Gijs from comment #3)
> > I mean, r=me, but the bug explicitly also calls out the toolbar button item.
> > Can we do the same thing there (when it's in the toolbar) ? Maybe as a
> > separate cset, but still on this bug?
> 
> This is already dealt with for this control[1] when it's in a toolbar, so I
> don't how Alice was able to get this behavior to reproduce there.
> 
> [1]
> http://searchfox.org/mozilla-central/source/browser/themes/shared/
> customizableui/panelUI.inc.css#1626

In case of the zoom widget is in toolbar, it was already fixed by Bug 1377184.
Flags: needinfo?(alice0775)
Iteration: --- → 57.3 - Sep 19
Priority: P4 → P1
https://hg.mozilla.org/mozilla-central/rev/736598341c09
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Tested using Mac OSX 10.12.5 and Windows 7 x 64 on latest Nightly 57.0a1 , Build ID 20170921100141. The issue is not reproducible anymore. The Zoom (in/out)buttons have fixed width to fit any scale/labe (when accessing from toolbar or hamburger menu).  I will mark this as Verified Fixed. Thank you
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1403675
You need to log in before you can comment on or make changes to this bug.