Closed Bug 1379368 Opened 2 years ago Closed 2 years ago

About pages lost the proper styling in SeaMonkey Classic theme

Categories

(SeaMonkey :: Themes, defect)

SeaMonkey 2.53 Branch
defect
Not set

Tracking

(seamonkey2.53 fixed, seamonkey2.54 fixed)

RESOLVED FIXED
seamonkey2.54
Tracking Status
seamonkey2.53 --- fixed
seamonkey2.54 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

Bug 1367326 removed some styling options from about.css in toolkit. 

Most SeaMonkey about: pages are now an unappealing gray mess with the classic theme.
REPRODUCIBLE with unzipped installer of  official en-US SeaMonkey 2.53a1 (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20170706013410  (Default Classic Theme) on German WIN7 64bit.

Was still ok with Build 20170620091523, appeared within 2.53

But FRG already knows all details :-)
Version: Trunk → SeaMonkey 2.53 Branch
Confirmed that Modern is not affected. It already has its own about.css
Attachment #8884620 - Flags: review?(rsx11m.pub)
Comment on attachment 8884620 [details] [diff] [review]
1379368-aboutcss.patch

Ok, so we are forking yet another CSS style sheet for the default theme (sigh).

Looks almost identical to prior mozilla-central changeset c92368a3d324, except for:

>+++ b/suite/themes/classic/communicator/about.css
>+ul {
>+  margin: 0;
>+  margin-inline-start: 1.5em;
>+  padding: 0;
>+}

There was a "list-style: square;" in that definition, we don't want that any more?
Most likely there is a reason, I'd just like to know it...
Attachment #8884620 - Flags: review?(rsx11m.pub) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/e85f8a58c5c1
Restore pre Photon styling for SeaMonkey about pages. r=rsx11m
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
> Ok, so we are forking yet another CSS style sheet for the default theme (sigh).

Yeahh. Thought first to do an overlay but with the default sheet looking like <BEEP>, likely needing a ton of changes and only 58 lines I can live with it.

> There was a "list-style: square;" in that definition, we don't want that any more?

ahh oehhh I hmm... Ok, maybe removed in error :) Didn't notice it. The default circles looked ok and almost identical. Thanks for catching it. Added back in the push.
Target Milestone: --- → seamonkey2.54
Comment on attachment 8884620 [details] [diff] [review]
1379368-aboutcss.patch

[Approval Request Comment]
Regression caused by (bug #):  1367326
User impact if declined: about pages look bland and unappealing.
Testing completed (on m-c, etc.): c-b 
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: --
Attachment #8884620 - Flags: approval-comm-beta?
Comment on attachment 8884620 [details] [diff] [review]
1379368-aboutcss.patch

a=me for c-b
Attachment #8884620 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.