Closed Bug 1379394 Opened 2 years ago Closed 2 years ago

Add a pref to allow disabling one-touch-pinch zoom gesture

Categories

(Core :: Panning and Zooming, defect, P2)

55 Branch
All
Android
defect

Tracking

()

VERIFIED FIXED
mozilla56
Tracking Status
firefox54 --- unaffected
firefox55 --- verified
firefox56 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

Bug 1111333 added support for the one-touch-pinch gesture (aka double-tap-drag zoom gesture) that allows one-handed zooming on touch devices. However there is no way to turn it off if users find it annoying. We should add a pref to allow disabling it.
Comment on attachment 8884549 [details]
Bug 1379394 - Add a pref to allow disabling the one-handed-zoom gesture in APZ.

https://reviewboard.mozilla.org/r/155430/#review160496

::: gfx/layers/apz/src/AsyncPanZoomController.cpp:291
(Diff revision 1)
>   * \li\b apz.min_skate_speed
>   * Minimum amount of speed along an axis before we switch to "skate" multipliers
>   * rather than using the "stationary" multipliers.\n
>   * Units: CSS pixels per millisecond
>   *
> + * \li\b apz.one_touch_pinch.enabled

I don't find it particularly helpful to have two names - "one-touch pinch" and "double-tap drag to zoom" - for the same feature.

Could we pick one, and stick to it?
Attachment #8884549 - Flags: review?(botond) → review+
Yeah I meant to stick with "one-touch-pimch" since that's what all the existing code uses.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4df531710d39
Add a pref to allow disabling the one-handed-zoom gesture in APZ. r=botond
https://hg.mozilla.org/mozilla-central/rev/4df531710d39
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment on attachment 8884549 [details]
Bug 1379394 - Add a pref to allow disabling the one-handed-zoom gesture in APZ.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1111333
[User impact if declined]: no way to disable the feature added, which can result in unexpected behaviour
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: adding a pref; default behaviour is unchanged
[String changes made/needed]: none
Attachment #8884549 - Flags: approval-mozilla-beta?
Comment on attachment 8884549 [details]
Bug 1379394 - Add a pref to allow disabling the one-handed-zoom gesture in APZ.

add a pref to control one-handed-zoom, beta55+
Attachment #8884549 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> [Is this code covered by automated tests?]: no
> [Has the fix been verified in Nightly?]: yes
> [Needs manual test from QE? If yes, steps to reproduce]: no

Setting qe-verify- based on Kartikaya's assessment on manual testing needs.
Flags: qe-verify-
Verified the apz.one_touch_pinch.enabled pref is added and works in about:config on Beta 55.0b8 (2017-11-07).
Devices:
-HTC Nexus 9 (Android 7.1.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.