Double-clicking the empty toolbar area while running in JWM causes Firefox to crash

RESOLVED DUPLICATE of bug 1186967

Status

()

P3
critical
RESOLVED DUPLICATE of bug 1186967
a year ago
a year ago

People

(Reporter: will.brokenbourgh2877, Unassigned)

Tracking

({crash})

52 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox56 wontfix, firefox57 wontfix, firefox58 wontfix)

Details

(Whiteboard: [JWM window manager], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8884605 [details]
Image showing where double-click was performed

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170630221752

Steps to reproduce:

When running the JWM window manager, double-clicking the empty toolbar area to the right of the [ + ] (new tab) button, Firefox maximizes.  When double-clicked again, Firefox crashes.

The red arrow in the attached image shows where I double-clicked to cause this crash.

This occurs on Debian Linux 64-bit, Void Linux 64-bit and FreeBSD 11.0 64-bit.


Actual results:

Firefox crashes after double-clicking the empty toolbar area to the right of the 'new tab' button.

Here is the related output on the terminal:

Gdk:ERROR:gdkwindow-x11.c:5165:create_moveresize_window: assertion failed: (mv_resize->moveresize_emulation_window == NULL)
Redirecting call to abort() to mozalloc_abort

[Child 1599] ###!!! ABORT: Aborting on channel error.: file /builddir/firefox-52.2.1esr/ipc/glue/MessageChannel.cpp, line 2152
[Child 1599] ###!!! ABORT: Aborting on channel error.: file /builddir/firefox-52.2.1esr/ipc/glue/MessageChannel.cpp, line 2152
Segmentation fault



Expected results:

Firefox should not have crashed.  On other window managers, the mouse pointer quickly turns to the 'drag' cursor then back to the default cursor when this area is double-clicked.
(Reporter)

Comment 1

a year ago
Bug report at the JWM github site: 
    https://github.com/joewing/jwm/issues/385

Comment 2

a year ago
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Keywords: crash, stackwanted
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 3

a year ago
(In reply to YF (Yang) from comment #2)
> https://developer.mozilla.org/en-US/docs/
> How_to_get_a_stacktrace_for_a_bug_report

The crash ID is: bp-e440280d-fdaf-4f77-a219-cb26f0170709

Updated

a year ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Updated

a year ago
Summary: Double-clicking the empty toolbar area in JWM causes Firefox to crash → Double-clicking the empty toolbar area while running in JWM causes Firefox to crash
Crash Signature: [@ mozalloc_abort | abort | libglib-2.0.so.0.5000.3@0x715a4]
(Reporter)

Comment 4

a year ago
This issue also occurs on TWM.  Additional operating system where this crash happens is OpenBSD 6.1 64-bit.
(Reporter)

Updated

a year ago
Keywords: stackwanted
(Reporter)

Comment 5

a year ago
Based on further testing, Firefox 45.0.2 was the last version that *didn't* crash when the empty space next to the 'New Tab' button is double-clicked.  Instead of crashing, 45.0.2 opens a new tab when the area in question is double-clicked.  45.0.2 also appears to be the last major Firefox version that is Gtk 2.  Looks like the issue might be based on the migration to Gtk 3.
In the past week I'm only seeing 11 crashes reported. Wontfixing this for 57 and 58, keeping open.
Status: UNCONFIRMED → NEW
status-firefox56: --- → wontfix
status-firefox57: --- → wontfix
status-firefox58: --- → wontfix
Ever confirmed: true
Comment hidden (advocacy)
Whiteboard: [JWM window manager]
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1186967
You need to log in before you can comment on or make changes to this bug.