Closed Bug 1379460 Opened 2 years ago Closed 2 years ago

Search from Searchbar/LocationBar fails when press [Enter] key quickly twice if current tab is about:home

Categories

(Firefox :: Search, defect, P2)

42 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Reproducible: always if current tab is about:home

Steps To Reproduce:
1. Open about:home 
2. Type something in SearchBar
3. press [Enter] key quickly twice

Actual Results:
Location Bar shows without query word.
https://www.google.co.jp/webhp?ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=2vNhWcuvC8vEXtTJuKgN
So, Google top page shows without search results.

Expected Results:
Search results should be shown
The problem is
Pres [Enter] key moves focus to search field of about:home <--- this is BUG
And then 2nd [Enter] performs search with empty text of search field of about:home

Search from Locationbar also fails.
Summary: Search from Searchbar fails when press [Enter] key quickly twice if current tab is about:home → Search from Searchbar/LocationBar fails when press [Enter] key quickly twice if current tab is about:home
(BTW, Pressing [Enter] twice for IME user's muscle memory)
I guess we should wait until something has loaded in the content area before moving the focus from the search (or location) bar to the content area.
Priority: -- → P2
Whiteboard: [fxsearch]
Flags: needinfo?(nhnt11)
I can no longer reproduce this, so I am going to resolve the bug. Please reopen if you can reproduce in the latest Nightly with similar steps.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.