Closed Bug 1379523 Opened 2 years ago Closed 2 years ago

js/src/jit/arm64/MoveEmitter-arm64.h:31:13: error: private field 'pushedAtSpill_' is not used [-Werror,-Wunused-private-field]

Categories

(Core :: JavaScript Engine: JIT, defect, P3)

ARM
FreeBSD
defect

Tracking

()

RESOLVED DUPLICATE of bug 1412513
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- affected
firefox55 --- affected
firefox56 --- affected

People

(Reporter: jbeich, Unassigned)

References

(Blocks 1 open bug)

Details

$ c++ -v
FreeBSD clang version 4.0.0 (tags/RELEASE_400/final 297347) (based on LLVM 4.0.0)
Target: aarch64-unknown-freebsd11.1
Thread model: posix
InstalledDir: /usr/bin

$ pkg install autoconf213 gmake python27
$ cd js/src/
$ autoconf-2.13
$ ./configure --disable-jemalloc --enable-warnings-as-errors
$ gmake
[...]
In file included from objdir/js/src/Unified_cpp_js_src21.cpp:11:
In file included from js/src/jit/arm64/MacroAssembler-arm64.cpp:9:
js/src/jit/arm64/MoveEmitter-arm64.h:31:13: error: private field
      'pushedAtSpill_' is not used [-Werror,-Wunused-private-field]
    int32_t pushedAtSpill_;
            ^
1 error generated.
Summary: js/src/jit/arm64/MoveEmitter-arm64.h:31:13: error: private fiel 'pushedAtSpill_' is not used [-Werror,-Wunused-private-field] → js/src/jit/arm64/MoveEmitter-arm64.h:31:13: error: private field 'pushedAtSpill_' is not used [-Werror,-Wunused-private-field]
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1412513
You need to log in before you can comment on or make changes to this bug.