Logitech Mouseware Scroll functions seem not to be supported

VERIFIED DUPLICATE of bug 20618

Status

SeaMonkey
UI Design
--
trivial
VERIFIED DUPLICATE of bug 20618
16 years ago
13 years ago

People

(Reporter: Nikolas A. Rathert, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

I am using a Trackball from Logitech together with the Logitech Mouseware
Drivers. The UniversalScroll function does not seem to work with this release of
mozilla. The "back" function I selected in the software is working properly.

Reproducible: Always
Steps to Reproduce:
1.click on the button you have assigned with the universal scroll feature
2. the icon appears but moving the ball has no effect on scrolling


Actual Results:  It won't scroll.

Expected Results:  scrolling should be possible by moving the ball of the
trackball instead of using the scrollbar on the right hand side.

Comment 1

16 years ago
This might be dupe of bug 20618.

Nikolas, please try using the latest Mouseware and turning off "Use Office97
scroll only". Does this fix the problem?

Comment 2

16 years ago
I'm having the same problem. Scrolling with my Logitech TrackMan FX doesn't
works (...and never worked). The difference is, that this mouse hasn't got a
scrollwheel.  It has a red button and pressing it hides the mousepointer and
allows you to scroll in every direction (with the normal trackball).

I just updated to the newest version of the Driver and disabled the "Office 97"
scroll-function to be sure.

Comment 3

16 years ago
Using: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2) Gecko/20020510
Build ID: 2002051006

I got a Cordless Mouseman Wheel from Logitech and I'm using the latest drivers
(9.60) on Windows 2000.

The universal scroll doesn't work for me if I push the button to which I
assigned this function.
But if I only hold the button down, without releasing it I can use the scrolling
functions as long as I keep the button pressed.

But in this case Mozilla will scroll only up and down, never left and right.

If I select the Auto Scroll function in the Logitech Mouse Settings the
scrolling works, but as before only up and down.

It would be nice if someone could confirm the bug.

Comment 4

16 years ago
@Stefan
It's exactly the same behaviour with my TrackManFX. (I tried to explain it in my
posting above)...
Didn't noticed that feature if I keep the button pressed. Danke viel mal(THX)!!

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 20618 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.