Update webrender to 479ae6475a18527206a2534c2b8a5bfb8b06bd6e

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

(Blocks: 1 bug)

unspecified
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(6 attachments)

+++ This bug was initially created as a clone of Bug #1374730 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ d7d482bc49d2af8394a4dbe142d2cf65e9629874

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d9689595733e9ec9e3ff235c5ed183db0e3b1fca
https://treeherder.mozilla.org/#/jobs?repo=try&revision=84df4791fdb4e407ce75fd3be3fd8a25163cbe28

Back to having an R7 failure. Regression range:

*   d7d482b Auto merge of #1457 - glennw:hinting, r=kvark
|\
| * 86c4e37 Make the selection of pt size in Freetype exactly match the gecko code.
| * ff4ba8b Use light hinting for Linux glyphs. This is a better default and matches glyphs exactly as Gecko draws them by default.
* 7367c0d Auto merge of #1464 - staktrace:neested, r=kvark
* 67c5f41 Fix typo in identifier name
servo/webrender#1457 caused a reftest failure in layout/reftests/stylesheet-cloning/counter-style-rule-clone.html - which is the same one that #1441 caused to fail (bug 1374730 comment 26). The reftest analyzer [1] shows visible differences, although the changes look better than what happened in #1441 (i.e. the text is evenly "thicker" as opposed to be thicker at the top and thin on the bottom). The test is already marked fuzzy for webrender but the fuzz is not enough to cover the new failure. I'm not sure if the change in behaviour is expected - if so we can increase the fuzz to cover the new difference.

[1] https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ToVN4to6QuyowIZBlD68RA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1
Created attachment 8886164 [details]
counter-style-rule-clone before/after screenshots

For posterity, this is what the reftest analyzer showed before and after servo/webrender#1457 changed the behaviour. After the PR, the "image" text got noticeably even thicker than the "reference" text, even though it was already thicker before.

This necessitates increasing the fuzz values to cover the difference.
WR @ 479ae6475a18527206a2534c2b8a5bfb8b06bd6e with bustage fixed, and the reftest fuzz increased:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e42fe24cee981359396fdd0f141f933b43181897
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e2157eaf7deae080f37ccc8d0d77575a44d94c1

Green (so far)

I'll get the patches up for review since glandium wants to pick up servo/webrender#1475.
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 479ae6475a18527206a2534c2b8a5bfb8b06bd6e
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment on attachment 8886192 [details]
Bug 1379604 - Update webrender_bindings for API change in WR cset 6824b35.

https://reviewboard.mozilla.org/r/157000/#review162062
Attachment #8886192 - Flags: review?(mrobinson) → review+

Comment 14

2 years ago
mozreview-review
Comment on attachment 8886188 [details]
Bug 1379604 - Update webrender to cset 479ae6475a18527206a2534c2b8a5bfb8b06bd6e.

https://reviewboard.mozilla.org/r/156992/#review162180
Attachment #8886188 - Flags: review?(jmuizelaar) → review+

Comment 15

2 years ago
mozreview-review
Comment on attachment 8886189 [details]
Bug 1379604 - Update versions in Cargo.toml/Cargo.lock files.

https://reviewboard.mozilla.org/r/156994/#review162182
Attachment #8886189 - Flags: review?(jmuizelaar) → review+

Comment 16

2 years ago
mozreview-review
Comment on attachment 8886190 [details]
Bug 1379604 - Update fuzz values on counter-style-rule-clone from WR cset ff4ba8b.

https://reviewboard.mozilla.org/r/156996/#review162186
Attachment #8886190 - Flags: review?(jmuizelaar) → review+

Comment 17

2 years ago
mozreview-review
Comment on attachment 8886191 [details]
Bug 1379604 - Update webrender_bindings for API change in WR cset d97598b.

https://reviewboard.mozilla.org/r/156998/#review162196

There's some new APIs that can also be exposed, but I'll handle that in my PR.
Attachment #8886191 - Flags: review?(a.beingessner) → review+

Comment 18

2 years ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e41daf74637e
Update webrender to cset 479ae6475a18527206a2534c2b8a5bfb8b06bd6e. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/62e217f1fec0
Update versions in Cargo.toml/Cargo.lock files. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/6518b2aec9de
Update fuzz values on counter-style-rule-clone from WR cset ff4ba8b. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/f02a30a0292b
Update webrender_bindings for API change in WR cset d97598b. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/5eb20b6ab3ad
Update webrender_bindings for API change in WR cset 6824b35. r=mrobinson
You need to log in before you can comment on or make changes to this bug.