bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Crash in shutdownhang | libsystem_kernel.dylib@0x16db6

RESOLVED DUPLICATE of bug 1389021

Status

()

Core
Graphics: Layers
--
critical
RESOLVED DUPLICATE of bug 1389021
a year ago
10 months ago

People

(Reporter: kats, Unassigned)

Tracking

({crash})

56 Branch
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, crash signature)

This bug was filed from the Socorro interface and is 
report bp-c1b7a63f-8471-4593-85de-b536e0170710.
=============================================================

I'm getting this shutdown hang/crash frequently when restarting Nightly for update on OS X. Looks like the compositor thread shutdown isn't happening properly. Seems to have started around the July 3rd buildid.

https://crash-stats.mozilla.com/report/index/d6035738-5368-40e7-86f8-c6fa10170708
https://crash-stats.mozilla.com/report/index/1db88875-7fba-449d-8d28-4a1c80170707
https://crash-stats.mozilla.com/report/index/613727d0-03b7-4e88-8213-5e6b30170707
https://crash-stats.mozilla.com/report/index/620dba15-6691-403c-a82e-03ebd0170704
I could not reproduce it on my Mac, but it seems like we have encountered a similar problem before[1].
Matt do you have any idea about this bug?

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1272614
Flags: needinfo?(mhowell)
See Also: → bug 1272614
Bug 1272614 was related to app update, which is my area, but I don't see it involved in any of these reports. I think this is a completely different shutdown hang, possibly hanging on shutting down the compositor thread, as :kats said.
Flags: needinfo?(mhowell)
I'm regularly having shutdownhang like bp-d9b0b557-3152-4bd3-a468-68d740170714 since 7/11. The stack looks identical to the original report but mine is linux.
Hello Kats, is there a way to know if the crash with this stack trace is still happening?
Flags: needinfo?(bugmail)
(In reply to Kevin Chen[:kechen] (UTC + 8) from comment #4)
> Hello Kats, is there a way to know if the crash with this stack trace is
> still happening?

Yeah, if you click on the crash signature link on this bug (it's in the "Details" section of the bug metadata) it will take you the crash-stats for it. You can then filter the search however you want. For example if you filter by version 57.0a1 it shows there are still 4 crash-reports, the most recent is on buildid 20170805100334 so I would say this is probably not fixed yet.
Flags: needinfo?(bugmail)
I think this signature contains more than one crash behavior.
They are all shutdown hang crashes, but the stack trace are very different.

Take the link[1] for example, there are 4 crash reports in 57.0a1, but two of them hang when shutting down XPCOM and two of them hang when closing nsUrlClassifierDBService; and these root causes are different from shutting down CompositorThreadHolder mentioned in comment 0.

Are the crashes have the same root cause? if not, maybe we should use this as a meta bug and trace the separate problems?
Also is there a good way to trace the situation with specific stack trace (e.g. I want to know if the CompositorThreadHolder shutdown hang is gone)?

[1] https://crash-stats.mozilla.com/signature/?version=57.0a1&signature=shutdownhang%20%7C%20libsystem_kernel.dylib%400x16db6&date=%3E%3D2017-08-02T07:12:00.000Z&date=%3C2017-08-09T07:12:00.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1
Flags: needinfo?(bugmail)
Yeah, you can filter for the stack trace using the "proto signature" field in crash-stats. If you search for "proto signature" "contains" "CompositorThread" for example you should see just the ones with the compositor thread shutdown hang. (Make sure to use the "contains" operator instead of "has terms").

https://crash-stats.mozilla.com/signature/?product=Firefox&proto_signature=~CompositorThread&signature=shutdownhang%20%7C%20libsystem_kernel.dylib%400x16db6&date=%3E%3D2017-05-09T13%3A24%3A43.000Z&date=%3C2017-08-09T13%3A24%3A43.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#summary
Flags: needinfo?(bugmail)
Bug 1389021 is working on the compositor thread shutdown problem.
Whiteboard: gfx-noted
Andrew, if this isn't a duplicate of bug 1389021, can you reopen it?
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1389021

Updated

10 months ago
Flags: needinfo?(aosmond)

Comment 10

10 months ago
Bug 1379619 is specific to Mac OS X.
Whereas Bug 1389021 is specific to Windows OS.

These bugs were marked as duplicates of each other. But with different operating systems being affected, and different crash signatures, should they be left separate instead? Maybe linked via "See Also"?

Or should the problems with both bugs and operating systems be merged? Changing the OS on Bug 1389021 from Windows to All.

Comment 11

10 months ago
(In reply to Andrew Osmond [:aosmond] from comment #96)
> (In reply to skywalker333 from comment #95)
> > Are these crash reports relevant? They appeared in Nightly recently.
> > 
> > 00e502a7-1bc6-4b77-a3f2-2627e0170919 	2017-09-19 15:35:04 	Firefox 	57.0a1 
> > 20170918220054 	Mac OS X 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS 	0x0 
> > 2017-09-19 15:12:59
> > 2a12f86b-5f6c-48db-ad9c-c588d0170917 	2017-09-17 00:37:59 	Thunderbird 
> > 57.0a1 	20170914030208 	Mac OS X 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS 	0x0
> > 2017-09-16 15:52:23
> > 3ad05691-0c7c-4c20-b645-127a50170916 	2017-09-16 15:06:09 	Firefox 	57.0a1 
> > 20170914100122 	Mac OS X 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS 	0x0 
> > 2017-09-15 04:31:26
> > 7c040dc6-f960-42dc-af21-cffef0170915 	2017-09-15 13:29:15 	Firefox 	57.0a1 
> > 20170914220209 	Mac OS X 	EXC_BAD_ACCESS / KERN_INVALID_ADDRESS 	0x0 
> > 2017-09-15 09:16:34
> 
> They are unrelated crashes, and should get a new bug. For the crash tracked
> by this bug, you should see CompositorThreadHolder::Shutdown in the crashing
> thread stack trace. Sadly the crash signature can't be made more specific
> (afaik).

So then these two bugs are not duplicates and should be kept separate.

[Bug 1379619 is specific to Mac OS X.
Whereas Bug 1389021 is specific to Windows OS.]
Status: RESOLVED → REOPENED
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox57: --- → affected
status-firefox-esr52: --- → affected
status-thunderbird_esr52: --- → unaffected
Resolution: DUPLICATE → ---
See Also: → bug 1389021
This bug, filed by me, is a duplicate of the one that was fixed. If you are seeing crashes please file a brand-new bug.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago10 months ago
status-firefox55: affected → ---
status-firefox56: affected → ---
status-firefox57: affected → ---
status-firefox-esr52: affected → ---
status-thunderbird_esr52: unaffected → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1389021

Comment 13

10 months ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #12)
> This bug, filed by me, is a duplicate of the one that was fixed. If you are
> seeing crashes please file a brand-new bug.

This bug is not a duplicate of the one that was fixed.

As per Andrew Osmond [:aosmond] from comment #96.

    "They are unrelated crashes"
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
The crash reports you linked were not the ones from comment 0 of this bug. Therefore unrelated to both this bug and the other bug. Therefore you need to stop reopening this bug and file another one.
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389021
You need to log in before you can comment on or make changes to this bug.