with FALSE in media.autoplay.enabled , the media loading still goes

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED INVALID
a year ago
8 months ago

People

(Reporter: Michael REMY, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

i went into about:config to put 'false' into media.autoplay.enabled  because i don't want any autostart video (media, audio or animation).
then i tried 2 examples :
https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_video_autoplay
http://www.html5videoplayer.net/html5video/mp4-h-264-video-test/


Actual results:

well ,for both the videos, there are no autostart ! 

but....

in the 1st example (w3schools), the mp4 file is fully loaded !!!
whereas in the 2nd example, the stop-loading is normal.



Expected results:

when autostart is disabled,  there should not be any load of content at all.

imagine the video size is huge like many MB bytes !
Component: General → Audio/Video
Product: SeaMonkey → Core
Version: SeaMonkey 2.46 Branch → 49 Branch
(Reporter)

Comment 1

a year ago
i know it is not the right place, but maybe...
For 15years of seamonkey i was always needed a feature like "Block videos from %domain%" like the super feature "Block images from %domain%" which is already in seamonkey.

So, putting "false" into "media.autoplay.enabled" config  may be the way to block any loading of video file in webpage (and autostart too).
My bandwidth's masters will appreciate & valide such a feature !
Component: Audio/Video → Audio/Video: Playback
We may want to load a little bit to let users see the frames quickly when users want to play it. But we also don't want to download too much data since users may not like to watch it.
Priority: -- → P3
See Also: → bug 1376321
I don't think it's a issue related with autoplay.
The video would still be loaded even the video doesn't have autoplay keyword, it's depend on the attribute  "preload" of the media element.
If you won't want to load too much data, maybe you should change the pref "media.cache_size" to smaller value, or change the pref "media.preload.default" to 1 (no-preload).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
See Also: bug 1376321
You need to log in before you can comment on or make changes to this bug.