stylo: Crash in do_QueryFrame::operator<T> nsIAnonymousContentCreator*

RESOLVED FIXED in Firefox 56

Status

()

P1
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: marcia, Assigned: bholley)

Tracking

(Blocks: 1 bug, {crash})

Trunk
mozilla56
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-88e599f9-e12a-4ba9-82d1-29b520170711.
=============================================================

Seen in crash stats: http://bit.ly/2tFdqYl

Some URLs:

https://www.lineageoslog.com/build
https://download.mokeedev.com/?device=hlte
Blocks: 1375906
(Assignee)

Comment 1

a year ago
So, I'm not really sure why do_QueryFrame is crashing, but given that this is during document teardown it seems possible that we may have destroyed the arena but not yet nulled out the element->frame pointer.

Either way, we call FragmentOrElement::DestroyContent, which calls nsBindingManager::RemovedFromDocumentInternal, which calls FragmentOrElement::SetXBLInsertionParent, which tries to recursively clear servo data from the subtree:

https://hg.mozilla.org/mozilla-central/annotate/0e41d07a703f/dom/base/FragmentOrElement.cpp#l1221

We really don't need to be doing that at all given that this is during teardown. So it might make sense to just clear the servo data at the top of FragmentOrElement::DestroyContent. I'll try.
Assignee: nobody → bobbyholley
(Assignee)

Comment 2

a year ago
Created attachment 8885427 [details] [diff] [review]
Drop style data in DestroyContent. v1

MozReview-Commit-ID: 9ydkvlDA9oS
Attachment #8885427 - Flags: review?(cam)
Comment on attachment 8885427 [details] [diff] [review]
Drop style data in DestroyContent. v1

Review of attachment 8885427 [details] [diff] [review]:
-----------------------------------------------------------------

I suppose this is OK, although I would prefer something less indirect, e.g. a check in FragmentOrElement::SetXBLInsertionParent that we're not in the middle of destroying the document (e.g. by checking nsDocument::mIsGoingAway, although that's not exposed).
Attachment #8885427 - Flags: review?(cam) → review+
Priority: -- → P1
(Assignee)

Comment 5

a year ago
Boris was concerned as to why we'd be hitting this, and was going to try reproducing locally.
Flags: needinfo?(bzbarsky)
So I tried adding checks to FragmentOrElement::DestroyContent to yell if GetPrimaryFrame() is non-null.  It never is, for me, on the urls in comment 0, as expected.

I tried installing uBlock Origin (since the crash dump above seems to have it installed), but that does not seem to change things.  Not sure whether one of the other addons is relevant here...

Anyway, the change in this bug makes sense to me, I think, though I agree it fixing the bug is not quite obvious.
Flags: needinfo?(bzbarsky)

Comment 7

a year ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/795947f535e8
Drop style data in DestroyContent. r=heycam,r=bz

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/795947f535e8
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.