Options page can no longer receive messages from the background page

VERIFIED FIXED in Firefox 56

Status

defect
P2
normal
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: gaubugzilla, Assigned: kmag)

Tracking

(Blocks 1 bug, {regression, testcase})

Trunk
mozilla56
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Posted file Test extension (obsolete) —
Steps to reproduce:

* Go to about:debugging and load the attached extension as a temporary extension.
* Go to about:addons, find "WebExtensions test" in the list and click its "Preferences" button.
* Press Ctrl/Cmd+Shift+J to open Browser Console, have a look at the messages.

Expected results:

Both "ping" and "pong" are listed in the Browser Console - the options page sent a message to the background page and received a response back. That's the behavior I see in Firefox 54 and Chrome 59.

Actual results:

Only "ping" is listed in the Browser Console, the response hasn't been received by the options page - tested with Firefox 56.0a1 nightly (2017-07-11) on Ubuntu. This affects both communication via plain messages and ports. I'm fairly certain that it used to work only a few days ago, so a pretty recent regression.
WFM in Nightly 56.0a1 (2017-07-11) x86 on Win10.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Posted file Test extension
My bad, not sure what went wrong with my testing. This seems to affect port-based communication only, which is what I was doing initially. I replaced the test extension by one using ports to communicate and verified that the issue is reproducible with a clean profile on Firefox 56.0a1 nightly (2017-07-12) on Ubuntu.
Attachment #8885669 - Attachment is obsolete: true
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=392ed89ec2730a48d10b1cec741e86a242d28aa3&tochange=a625a2e9b3333a8e76982ea65f077cfded6ac224
Blocks: webext-oop
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Strange, extensions.webextensions.remote isn't the default on Linux and was indeed off for me. Which doesn't mean of course that it isn't a side-effect of one of those changes.
Comment on attachment 8885967 [details]
Bug 1380290: Use correct message manager when communicating with inline options browsers.

https://reviewboard.mozilla.org/r/156750/#review162112

eeew
Attachment #8885967 - Flags: review?(aswan) → review+
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ce83907a2bc
Use correct message manager when communicating with inline options browsers. r=aswan
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/9ce83907a2bc
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Assignee: nobody → kmaglione+bmo
I was able to reproduce the initial issue on Firefox 56.0a1 (2017-07-09) under Windows 10 64-bit.
Verified as fixed on Firefox 56.0a1 (2017-08-01) and Firefox 57.0a1 (2017-08-02) under Windows 10 64-bit and Ubuntu 16.04 32-bit. Both "ping" and "pong" are listed in the Browser Console.
Status: RESOLVED → VERIFIED
I forgot to retest this issue. In Firefox 57.0a1 (2017-08-02) on Ubuntu everything seems to be working as well, Easy Passwords 1.2.1 options are working - it has been released as a Web Extension in the meantime.
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.