file query blanks not writeable

RESOLVED DUPLICATE of bug 78928

Status

()

Core
Event Handling
--
major
RESOLVED DUPLICATE of bug 78928
16 years ago
15 years ago

People

(Reporter: Karen Bruner, Assigned: joki (gone))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.9) Gecko/20020416
BuildID:    00000000000

If I open the query for a link to follow (using Ctl-Shift-L) the
window comes up fine but I cannot edit the existing text.  I can highlight it,
but it seems to be using the X cut-and-paste control rather than mozilla's entry
widget. Highlighting and backspacing do not affect the entry content at all. 
This also happens when I open the file chooser widget, I cannot change the text
in the chooser blank.  The associated pull-down menus work fine.  I can only use
the default.  Normal in-browser forms seem to work and the location blank on the
Navigator Toolbar are also normal.

Reproducible: Always
Steps to Reproduce:
1.Open Ctl-Shift-L
2.Attempt to change value in fill-in text blank
3.

Actual Results:  Text in blank is not editable by keyboard.

Expected Results:  Allowed keyboard modification of text in blank

Updated

16 years ago
QA Contact: madhur → rakeshmishra
Can you edit text in the "Find" dialog, eg?

What windowmanager are you using?
(Reporter)

Comment 2

16 years ago
vtwm-5.4.6, but it shows the same behavior if I run or start it with no window
manager running.  It *does* seem to work correctly if I use fvwm.  I'm not sure
I want to.
Karen, thanks for the information.... This is a problem in how Mozilla handles
lack of certain windowmanager events (which is why it fails with no
windowmanager as well).

duplicate of "twm or no wm: Cannot type into dialog text fields"

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.