Some PerformanceTiming object properties are missing from the Object Inspector in the console - getter properties are not supported

VERIFIED FIXED in Firefox 56

Status

()

Firefox
Developer Tools: Console
P1
normal
VERIFIED FIXED
6 months ago
6 months ago

People

(Reporter: cpeterson, Assigned: nchevobbe)

Tracking

unspecified
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 unaffected, firefox55 unaffected, firefox56+ verified)

Details

(Whiteboard: [reserve-console-html])

(Reporter)

Description

6 months ago
[Tracking Requested - why for this release]:

This is a regression in Nightly 56 from devtools console bug 1308566.

STR:
1. Open devtools console.
2. Enter `performance.timing` at the console and press Enter.

RESULT:
The PerformanceTiming object is dumped to the console:

PerformanceTiming { navigationStart: 1499900753244, unloadEventStart: 0, unloadEventEnd: 0, redirectStart: 0, redirectEnd: 0, fetchStart: 1499900753245, domainLookupStart: 1499900753259, domainLookupEnd: 1499900753334, connectStart: 1499900753335, connectEnd: 1499900753369 }

But it is missing some PerformanceTiming properties such as:

domComplete
domContentLoadedEventEnd
domContentLoadedEventStart
domInteractive
domLoading
loadEventEnd
loadEventStart
requestStart
responseEnd
responseStart

Note these properties are *also* missing from the object dumped in Firefox <= 55, but these properties can be inspected in the variables view column if you click on the PerformanceTiming object in the console.

https://developer.mozilla.org/en-US/docs/Web/API/PerformanceTiming

Updated

6 months ago
Whiteboard: [console-html] [triage]
Thanks for the report. This isn't a problem in the debugger if I enter `performance.timing` as a watch expression (I see domComplete, etc). Jason, do you have an idea why the debuggers's Object Inspector is showing more information than the console's?
Flags: needinfo?(jlaster)

Updated

6 months ago
Flags: qe-verify+
Priority: -- → P2
QA Contact: iulia.cristescu
Whiteboard: [console-html] [triage] → [console-html]

Comment 2

6 months ago
That's because these properties are accessor properties, not data properties. See bug 1380504.

Comment 3

6 months ago
We currently set getter properties and properties for the OI. We probably could do something in the Object Inspector to support getters separately, but that was out of scope at the time.

https://github.com/devtools-html/debugger.html/blob/master/src/client/firefox/commands.js#L196-L199
Flags: needinfo?(jlaster)
OK, going to dupe Bug 1380504 to this one since it's already being tracked for 56.  This will be fixed in Reps at https://github.com/devtools-html/devtools-core/issues/397
Summary: Some PerformanceTiming object properties are missing from the Object Inspector in the console → Some PerformanceTiming object properties are missing from the Object Inspector in the console - getter properties are not supported
Duplicate of this bug: 1380504
(Assignee)

Updated

6 months ago
Depends on: 1380790

Comment 6

6 months ago
Track 56+ as new regression in 56.
tracking-firefox56: ? → +

Updated

6 months ago
Priority: P2 → P3
Whiteboard: [console-html] → [reserve-console-html]
This is fixed on m-c in Bug 1380790, will wait until it hits Nightly tomorrow for confirmation
(Assignee)

Comment 8

6 months ago
The fix landed in latest Nightly (56.0a1 (2017-07-28)), Chris, is it working as expected for you ?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 9

6 months ago
(In reply to Nicolas Chevobbe [:nchevobbe] from comment #8)
> The fix landed in latest Nightly (56.0a1 (2017-07-28)), Chris, is it working
> as expected for you ?

Yes. I see domComplete and the other missing performance.timing properties when I expand the PerformanceTiming object's list of properties. It would be nice if all the properties were listed in the compact object representation, but this is the current behavior as Firefox 54 so this regression has been fixed.

compact object representation:

PerformanceTiming { navigationStart: 1501259972917, unloadEventStart: 0, unloadEventEnd: 0, redirectStart: 0, redirectEnd: 0, fetchStart: 1501259972918, domainLookupStart: 1501259972918, domainLookupEnd: 1501259972918, connectStart: 1501259972918, connectEnd: 1501259972918 }

expanded property list:

connectEnd : 1501259972918
connectStart : 1501259972918
domComplete : 1501259974344
domContentLoadedEventEnd : 1501259974291
domContentLoadedEventStart : 1501259974213
domInteractive : 1501259974151
domLoading : 1501259973963
domainLookupEnd : 1501259972918
domainLookupStart : 1501259972918
fetchStart : 1501259972918
loadEventEnd : 1501259974345
loadEventStart : 1501259974344
navigationStart : 1501259972917
redirectEnd : 0
redirectStart : 0
requestStart : 1501259972993
responseEnd : 1501259973953
responseStart : 1501259973923
secureConnectionStart : 1501259972917
timeToNonBlankPaint : 1501259974180
unloadEventEnd : 0
unloadEventStart : 0
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox56: affected → verified
Flags: needinfo?(cpeterson)
Resolution: --- → FIXED

Updated

6 months ago
Status: RESOLVED → VERIFIED
Iteration: --- → 56.4 - Aug 1
Flags: qe-verify+
Priority: P3 → P1
Assignee: nobody → nchevobbe
Target Milestone: --- → Firefox 56
You need to log in before you can comment on or make changes to this bug.