Closed Bug 1380629 Opened 2 years ago Closed 2 years ago

In latest nightly switching to the classical theme in Windows 7 breaks user interface for Firefox

Categories

(Core :: Widget: Win32, defect, major)

56 Branch
Unspecified
Windows 7
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 + fixed

People

(Reporter: 8a9f76+21ed5nc7zq5jk, Assigned: dthayer)

References

Details

(Keywords: regression)

Attachments

(5 files)

Attached image classical.PNG
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

Use the classical theme (the one that looks like Windows 2000 or earlier) in Windows 7 (instead of the default aero theme).


Actual results:

Firefox interface was broken (see included screenshots).


Expected results:

Firefox interface should not be broken.
Issue does not happen with default theme for Windows 7 (see attached below).
Attached image default.PNG
OS: Unspecified → Windows 7
Component: Untriaged → Theme
Might be caused by Photon work.
Whiteboard: [photon-visual][triage]
Regression window is:

Last good nightly:
20170711030203
https://hg.mozilla.org/mozilla-central/rev/0e41d07a703f19224f60b01577b2cbb5708046c9

First bad nightly:
20170712030204
https://hg.mozilla.org/mozilla-central/rev/09a4282d1172ac255038e7ccacfd772140b219e2
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Depends on: 1373079
Backing out Bug 1373079 locally made it work for me again in SeaMonkey so I think it should be the same for Firefox.
Not Photon-related then.
Whiteboard: [photon-visual][triage]
Component: Theme → Widget: Win32
Product: Firefox → Core
This actually breaks the UI so badly that in many cases it is impossible to exit Firefox because of no working menus or way to close the window.  Only way out is to use the task manager to end the process.
I can verify that backing out bug 1373079 fixes this for Firefox as well.
Assignee: nobody → dothayer
Status: NEW → ASSIGNED
Still experiencing strange UI here when testing Hasal.

the new config onboarding hints/suggestion also broke the UI in classic theme (performance theme).
FYI for me all the dialogs like "About Firefox", "Clear private data" (ctrl-shift-del) have 0 height due to this.
OTOH menu entries have width of 100% screen width (regardless of Firefox window width).

This is a pretty huge regression.
Start with -P option, as a result, profile selection dialog is completely black.
And, right click on tabbar, as a result, an empty menupopup is displayed throughout the window.

Tested Nightly56.0a1 32bit(HWA is blocked) on windows7 sp1 x64 VMWare guest.
[Tracking Requested - why for this release]:
Blocks: 1373079
No longer depends on: 1373079
Attached image win7_20170717.png
This is current Nightly build. With launching of onboarding notification, the firefox would just crash and hang there. User can do nothing in that case.

The UI would still be bad with the following about:config modification, but Firefox would, at least, function okay.

"browser.onboarding.enabled": false,
"browser.onboarding.hidden": true,
"browser.onboarding.notification.finished": true
Comment on attachment 8887232 [details]
Bug 1380629 - Check GetTheme result in nsNativeThemeWin

https://reviewboard.mozilla.org/r/158028/#review163888
Attachment #8887232 - Flags: review?(jmathies) → review+
Pushed by dothayer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/42880c35739e
Check GetTheme result in nsNativeThemeWin r=jimm
May as well track this to make sure it lands. Thanks for the quick fix!
https://hg.mozilla.org/mozilla-central/rev/42880c35739e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.