Closed Bug 1380665 Opened 3 years ago Closed 3 years ago

Define MOZ_CODE_COVERAGE for the entire tree instead of individually in several moz.build files

Categories

(Testing :: Code Coverage, enhancement)

Version 3
enhancement
Not set
normal

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: marco, Assigned: marco)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

We're currently adding MOZ_CODE_COVERAGE to DEFINES in several moz.build files throughout the tree, it would be better to just define it for the entire tree.
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attachment #8886195 - Flags: review?(jmaher)
Attached patch PatchSplinter Review
I had to remove MOZ_CODE_COVERAGE from old-configure.in, otherwise it would have been added to config twice.

Here's a green try build: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6549b982544def517db9656cd4fe1c5d92ef4f20

The mozinfo.json contains correct info ("ccov" is true): https://public-artifacts.taskcluster.net/V4zpl-GWS4alC7XLuZfIXg/0/public/build/target.mozinfo.json.
Attachment #8886195 - Attachment is obsolete: true
Attachment #8886195 - Flags: review?(jmaher)
Attachment #8886296 - Flags: review?(jmaher)
Comment on attachment 8886296 [details] [diff] [review]
Patch

Review of attachment 8886296 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!
Attachment #8886296 - Flags: review?(jmaher) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/32aa8aa9330b
Define MOZ_CODE_COVERAGE for the entire tree. r=jmaher
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/32aa8aa9330b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Blocks: 1054275
Duplicate of this bug: 1380663
You need to log in before you can comment on or make changes to this bug.