Closed Bug 1380800 Opened 2 years ago Closed 2 years ago

stylo: Crash in InvalidArrayIndex_CRASH | nsTArray_Impl<T>::ElementAt | mozilla::ServoCSSRuleList::GetRule

Categories

(Core :: CSS Parsing and Computation, defect, P1, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: mccr8, Assigned: xidorn)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-8b2d4314-ad9d-4786-96c2-1cf430170713.
=============================================================

11 crashes from 2 installations in the last 7 days. For all of them, the array is empty, and we're trying to access element 0.
Flags: needinfo?(xidorn+moz)
My fault... Stupid bug...
Assignee: nobody → xidorn+moz
Flags: needinfo?(xidorn+moz)
Comment on attachment 8886466 [details]
Bug 1380800 - Correct index check in ServoStyleSheet.deleteRule.

https://reviewboard.mozilla.org/r/157262/#review162378

I overlooked it too when reviewing.  Thanks for the quick fix!
Attachment #8886466 - Flags: review?(cam) → review+
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/89603a95a868
Correct index check in ServoStyleSheet.deleteRule. r=heycam
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/89603a95a868
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.