move CacheFileMetadata::GetElement out of lambda

RESOLVED FIXED in Firefox 55

Status

()

Core
Networking: Cache
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: junior, Assigned: junior)

Tracking

(Blocks: 2 bugs)

unspecified
mozilla56
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox55 fixed, firefox56 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

(Assignee)

Description

3 months ago
Per bug 1352916 comment 20, we'd like to have a try for moving CacheFileMetadata::GetElement out of lambda.
(Assignee)

Comment 1

3 months ago
Created attachment 8886492 [details] [diff] [review]
outOfLambda, v1
Attachment #8886492 - Flags: review?(michal.novotny)
(Assignee)

Updated

3 months ago
Whiteboard: [necko-active]
(Assignee)

Comment 2

3 months ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=737df8aec1791026547664c006dc8bc84d22eb0d
Attachment #8886492 - Flags: review?(michal.novotny) → review+
(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Comment 3

3 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d90c8018a22f
Try to solve crash: move GetElement out of lambda. r=michal
Keywords: checkin-needed

Comment 4

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d90c8018a22f
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
(Assignee)

Comment 5

3 months ago
Comment on attachment 8886492 [details] [diff] [review]
outOfLambda, v1

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1325088
[User impact if declined]:Crash, 3-15 crashes per day in beta now
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]:Yes, no such crash happen after this bug
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]:no
[Is the change risky?]:almost no risk
[Why is the change risky/not risky?]:small logic change in code
[String changes made/needed]:no
Attachment #8886492 - Flags: approval-mozilla-beta?
(Assignee)

Updated

3 months ago
Duplicate of this bug: 1352916
Comment on attachment 8886492 [details] [diff] [review]
outOfLambda, v1

crash fix for beta55

it's closer to 100 crashes a day than 3-15...  Should be in 55.0b11
Attachment #8886492 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 8

3 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/20b0f0b4a612
status-firefox55: --- → fixed
(In reply to Junior[:junior] from comment #5)
> [Is this code covered by automated tests?]:No
> [Has the fix been verified in Nightly?]:Yes, no such crash happen after this
> bug
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify- based on Junior's assessment on manual testing needs.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.