Closed Bug 1381340 Opened 2 years ago Closed 2 years ago

disable h2 origin extension for gecko 55

Categories

(Core :: Networking: HTTP, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox55 --- fixed
firefox56 --- unaffected

People

(Reporter: mcmanus, Assigned: mcmanus)

References

Details

Attachments

(1 file)

This patch just disables a new 55 feature, the origin h2 extension, via a pref.

There is nothing known to be wrong with the feature, however the standards track for it is not finishing up as quickly as I had anticipated and I'm worried about the potential for non compatible changes... so I would rather wait another 6 weeks to get it out on release (or at least a few weeks to evaluate again) for 56.
Comment on attachment 8886884 [details]
Bug 1381340 - Disable H2 origin extension on gecko-55

https://reviewboard.mozilla.org/r/157618/#review162726
Attachment #8886884 - Flags: review?(dd.mozilla) → review+
Comment on attachment 8886884 [details]
Bug 1381340 - Disable H2 origin extension on gecko-55

Approval Request Comment
[Feature/Bug causing the regression]: 1337791 - new feature on 55 that may still be subject to change due to standards process. this patch just disables the feature via pref

[User impact if declined]: its possible that down the road non-updated firefox 55 users would see flaky behavior with the feature if servers interpreted it differently.

[Is this code covered by automated tests?]: yes. and the test turns the pref on to continue testing.

[Has the fix been verified in Nightly?]: no. this only applies to 55 at this time. I hope the standards situation will be sorted out for 56.

[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]:not at all
[Why is the change risky/not risky?]: disable new feature via pref is an expected mechanism
[String changes made/needed]: none
Attachment #8886884 - Flags: approval-mozilla-beta?
Comment on attachment 8886884 [details]
Bug 1381340 - Disable H2 origin extension on gecko-55

turn off network.http.originextension for 55.  should be in 55.0b10
Attachment #8886884 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee: nobody → mcmanus
https://hg.mozilla.org/releases/mozilla-beta/rev/e2c266490851
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
thanks!
(In reply to Patrick McManus [:mcmanus] from comment #3)
> [Is this code covered by automated tests?]: yes. and the test turns the pref
> on to continue testing.
> 
> [Has the fix been verified in Nightly?]: no. this only applies to 55 at this
> time. I hope the standards situation will be sorted out for 56.
> 
> [Needs manual test from QE? If yes, steps to reproduce]: no

Setting qe-verify- based on Patrick's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.