Closed Bug 1381347 Opened 7 years ago Closed 7 years ago

UnknownCommandException: quit for firefox-ui update tests with Firefox 53

Categories

(Remote Protocol :: Marionette, defect)

defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: whimboo, Assigned: ato)

References

Details

(Keywords: regression)

Attachments

(1 file)

Our Firefox UI update tests will show bustage after the next merge from mozilla-central to mozilla-beta, because the changes on bug 1337743 are not backward compatible. Especially `quit` doesn't have a fallback anymore. 

This especially happens with Firefox 53 where we still support updates from for a target version of 56. Newer versions like 54 and 55 should work because of the changes in bug 1337743.

We should leave the fallback for at least another cycle.

Andreas, can you please fix that? Thanks.
Flags: needinfo?(ato)
Summary: TEST-UNEXPECTED-ERROR | test_minimized.py TestMinimizedTestCase.test | UnknownCommandException: quit (Firefox-UI update tests) → UnknownCommandException: quit for firefox-ui update tests with Firefox 53
Flags: needinfo?(ato)
Assignee: nobody → ato
Status: NEW → ASSIGNED
Comment on attachment 8887177 [details]
Bug 1381347 - Use deprecated quitApplication command in Marionette client;

https://reviewboard.mozilla.org/r/157922/#review163430
Attachment #8887177 - Flags: review?(hskupin) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af7b2525a934
Use deprecated quitApplication command in Marionette client; r=whimboo
https://hg.mozilla.org/mozilla-central/rev/af7b2525a934
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Product: Testing → Remote Protocol
You need to log in before you can comment on or make changes to this bug.