Closed Bug 1381419 Opened 2 years ago Closed Last year

[META] Convert JSTerm (Console input) to a Redux/React App

Categories

(DevTools :: Console, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1425519

People

(Reporter: nchevobbe, Unassigned)

References

(Blocks 1 open bug)

Details

At the moment, it isn't simple to work on the Console Input (also known as JSTerm), because the flow of it is hard to grasp.
Since we already move the console (and other devtools) to React/Redux, I think it would be a good thing to do the same thing for the jsterm.

We could use the jsterm-stub file we have in the launchpad as a starting point to do this refactor.
Nicolas, isn't this dup of bug 1425519 ?

Honza
Flags: needinfo?(nchevobbe)
It is :)
Thanks for pointing this out
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(nchevobbe)
Resolution: --- → DUPLICATE
Duplicate of bug: 1425519
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.