Closed Bug 1381579 Opened 2 years ago Closed 2 years ago

Remove async from functions in ExtensionPreferencesManager that don't need to be async

Categories

(WebExtensions :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1381605

People

(Reporter: bsilverberg, Assigned: bsilverberg)

References

Details

(Whiteboard: triaged)

Attachments

(1 obsolete file)

We updated the ExtensionSettingsStore to remove async from the functions that didn't need to be async, and now we should do the same for ExtensionPreferencesManager which makes use of the ExtensionSettingsStore.
Depends on: 1381605
Comment on attachment 8887175 [details]
Bug 1381579 - Remove async from functions in ExtensionPreferencesManager that don't need to be async,

Obsoleting this patch for now, as bug 1381605 should be addressed first.
Attachment #8887175 - Attachment is obsolete: true
Attachment #8887175 - Flags: review?(aswan)
The work described in this bug was done as part of bug 1381605.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381605
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.