Closed Bug 1381670 Opened 4 years ago Closed 4 years ago

stylo: transition doesn't work correctly presumably because of pseudo-elements

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1380133

People

(Reporter: xidorn, Unassigned)

References

(Blocks 1 open bug)

Details

I haven't worked out a simplified bug... just file a bug in case I forgot.

Steps to reproduce:
1. open my homepage https://www.upsuper.org/
2. click the switch at the right-bottom corner to switch the theme.

In Firefox, the whole background changes the color smoothly, while with Stylo, the links area changes immediately, and the logo doesn't change in the same speed as other areas. The switch itself also seems to jump to the other side directly rather than moving smoothly.

Not sure whether this is some known issue.
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #0)
> I haven't worked out a simplified bug... just file a bug in case I forgot.

simplified testcase, I mean.
Priority: -- → P2
Hiro-san, it seems you're working on relevant bug now. Is it in different cause or just a dupe?
Flags: needinfo?(hikezoe)
As far as I can tell there are a couple of animation issues. One is flickering issue, I guess it will be fixed by Cameron's patch (bug 1380133).

I guessed another one was what I am trying to fix (bug 1381431 and 1378064), but it seems not since the Xidorn's site does not cause the assertions at all. So I think it's worth investigating this issue separately.
Flags: needinfo?(hikezoe)
Another interesting symptom is that, if you move the pointer onto the links during the background transition, the transition for :hover wouldn't be triggered either. To reproduce this easier, you can change the "--theme-time" property at <html> element to something longer, e.g. 10s, so that you have more time to hover the links.
According to Cameron's manual testing, looks like this can be fixed by bug 1380133.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380133
You need to log in before you can comment on or make changes to this bug.