Firefox Screenshots icon briefly shows then disappears

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: asa, Assigned: jgruen)

Tracking

unspecified
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55+ fixed, firefox56 verified)

Details

(Reporter)

Description

2 years ago
On a new profile with latest nightly on launch I see the Firefox Screenshots icon appear and then disappear from the far right of the main toolbar. 

Tested with 7/18 build 

This icon should never show if it's not supposed to or it should stay put if it's supposed to.

Comment 1

2 years ago
Can you provide a screenshot of what you're seeing?
Component: Toolbars and Customization → Screenshots
Flags: needinfo?(asa)
Product: Firefox → Cloud Services
Version: Trunk → unspecified

Comment 2

2 years ago
(In reply to :Gijs from comment #1)
> Can you provide a screenshot of what you're seeing?

err, I meant screencast. :-)
(Reporter)

Comment 3

2 years ago
https://youtu.be/2hLEL0NNdco
Flags: needinfo?(asa)
(Reporter)

Comment 4

2 years ago
(In reply to Asa Dotzler [:asa] from comment #3)
> https://youtu.be/2hLEL0NNdco

You'll want to skip the first 40 seconds or so (that's normal startup time on this machine.)

Comment 5

2 years ago
(In reply to Asa Dotzler [:asa] from comment #4)
> (In reply to Asa Dotzler [:asa] from comment #3)
> > https://youtu.be/2hLEL0NNdco
> 
> You'll want to skip the first 40 seconds or so (that's normal startup time
> on this machine.)

Thanks! Yeah, this looks like a screenshots issue to me, it's not being removed entirely (there's too much space left at the end - can you still hover over it if you aim for the middle of the toolbar, getting a bizarrely small little square for a hover state with no icon in it?) and not being put in the overflow menu or something, so I think the add-on must be doing something to remove the icon, or try to use an icon that's not being packaged or something. Hopefully :ian or :jgruen know more.


Also, bizarrely, I just noticed I'm seeing this myself on 55 beta. On my main profile on my mbp. I'll see if I can find something out...
status-firefox55: --- → affected
status-firefox56: --- → affected
tracking-firefox55: --- → ?
(Reporter)

Comment 6

2 years ago
(In reply to :Gijs from comment #5)

> removed entirely (there's too much space left at the end - can you still
> hover over it if you aim for the middle of the toolbar, getting a bizarrely
> small little square for a hover state with no icon in it?) 

Yes. There is a little gray square on mouseover where the screenshots icon used to be. If I click it the icon returns and screenshot functionality starts up.
(Assignee)

Comment 7

2 years ago
:asa :gijs

This is a known issue and should be resolved by https://bugzilla.mozilla.org/show_bug.cgi?id=1381132
(Assignee)

Updated

2 years ago
Depends on: 1381132
(Reporter)

Comment 8

2 years ago
Great! Sorry for the duplicate :)
One issue we've seen in Screenshots is the icon going missing, because the path to the icon was incorrect. That is the bug fix contained in bug 1381132.

I think this is likely a dupe, but some discussion in the teamaddons channel suggests that we may not be shutting down correctly as part of the update process.

Gijs, did you see anything to suggest this was a bigger issue than a missing icon?

Hopefully, by the time you read this, the patch in bug 1381132 will have landed, and we'll be able to determine if this bug is a dupe or not.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 10

2 years ago
(In reply to Jared Hirsch [:_6a68] [:jhirsch] from comment #9)
> One issue we've seen in Screenshots is the icon going missing, because the
> path to the icon was incorrect. That is the bug fix contained in bug 1381132.
> 
> I think this is likely a dupe, but some discussion in the teamaddons channel
> suggests that we may not be shutting down correctly as part of the update
> process.
> 
> Gijs, did you see anything to suggest this was a bigger issue than a missing
> icon?

Well, none of the URLs (including parent directories etc.) seem to work in the URL bar on beta. I don't know if that is just a bug in our moz-extension handling. I also saw that the startup promise was pending when requesting the webextension object from legacyextensionsutils - which, again, could be a webextensions bug? Not sure.
Flags: needinfo?(gijskruitbosch+bugs)
status-firefox54: --- → unaffected
status-firefox57: affected → ---
status-firefox-esr52: --- → unaffected
tracking-firefox55: ? → +
Duplicate of this bug: 1381394
Assignee: nobody → jgruen

Updated

2 years ago
Duplicate of this bug: 1382541
This is fixed in the latest versions.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I have reproduced this bug with Nightly 56.0a1 (2017-07-18) on Ubuntu 16.04, 64 bit!

The fix is now verified on Latest Nightly 56.0a1 .

Build ID 	20170727100240
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0

[bugday-20170726]
status-firefox55: affected → fixed
status-firefox56: affected → verified
Target Milestone: --- → mozilla56
Target Milestone: mozilla56 → Firefox 56

Updated

2 years ago
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.