Fix a typo about MOZ_CONTAINER_GET_CLASS macro

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kenhys, Assigned: kenhys)

Tracking

Trunk
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170616222023

Steps to reproduce:

Checkout latest source.

$ hg clone https://hg.mozilla.org/mozilla-central/ src
$ cd src
$ less widget/gtk/mozcontainer.h


Actual results:

I've found a typo about MOZ_CONTAINER_GET_CLASS macro

diff --git a/widget/gtk/mozcontainer.h b/widget/gtk/mozcontainer.h
--- a/widget/gtk/mozcontainer.h
+++ b/widget/gtk/mozcontainer.h
@@ -46,7 +46,7 @@
 #define MOZ_CONTAINER_CLASS(klass)    (G_TYPE_CHECK_CLASS_CAST ((klass), MOZ_CONTAINER_TYPE, MozContainerClass))
 #define IS_MOZ_CONTAINER(obj)         (G_TYPE_CHECK_INSTANCE_TYPE ((obj), MOZ_CONTAINER_TYPE))
 #define IS_MOZ_CONTAINER_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE ((klass), MOZ_CONTAINER_TYPE))
-#define MOZ_CONAINTER_GET_CLASS(obj)  (G_TYPE_INSTANCE_GET_CLASS ((obj), MOZ_CONTAINER_TYPE, MozContainerClass))
+#define MOZ_CONTAINER_GET_CLASS(obj)  (G_TYPE_INSTANCE_GET_CLASS ((obj), MOZ_CONTAINER_TYPE, MozContainerClass))
 


Expected results:

It should be MOZ_CONTAINER_GET_CLASS.

There is no side-effects by fixing a typo because this macro definition is
not used in actual implementation.
(Assignee)

Comment 1

2 years ago
Comment on attachment 8887838 [details] [diff] [review]
fix-a-typo-moz-container-get-class.patch

Could you review this patch?
Attachment #8887838 - Flags: review?(karlt)
Attachment #8887838 - Flags: review?(karlt) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Assignee: nobody → kenhys

Comment 2

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/41a7b32bdfeb
Fix a typo about MOZ_CONTAINER_GET_CLASS definition. r=karlt
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/41a7b32bdfeb
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.