Closed Bug 1382327 Opened 2 years ago Closed 2 years ago

(reftest) Change reftest-print to reftest-paged

Categories

(Testing :: Reftest, enhancement)

enhancement
Not set

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: tschneider, Assigned: tschneider)

References

Details

Attachments

(1 file, 3 obsolete files)

Based on discussions in Bug 1299848, reftest-print should be renamed to reftest-paged, cause testing pagination is what those test are actually doing. This will avoid confusion with real printing reftests.
Summary: Change reftest-print to reftest-paged → (reftest) Change reftest-print to reftest-paged
Blocks: 1299848
Rebased patch
Attachment #8888012 - Attachment is obsolete: true
Updated patch
Attachment #8888023 - Attachment is obsolete: true
Comment on attachment 8889263 [details] [diff] [review]
Rename reftest-print to reftest-paged

David, as suggested in https://bugzilla.mozilla.org/show_bug.cgi?id=1299848#c23, the first step before landing bug 1299848 should be renaming the existing reftest-print to reftest-paged to avoid confusion. This patch is mostly doing that. only code change is https://bugzilla.mozilla.org/attachment.cgi?id=8889263&action=diff#a/layout/tools/reftest/reftest-content.js_sec2 which throws if previous naming is being used.
Attachment #8889263 - Flags: review?(dbaron)
Comment on attachment 8889263 [details] [diff] [review]
Rename reftest-print to reftest-paged

>+        if (classList.indexOf("reftest-print") > -1) {

Please use "!= -1" rather than "> -1"



You've also made encoding changes in these tests:
layout/base/crashtests/363729-2.html
layout/base/crashtests/363729-3.html
layout/generic/crashtests/570160.html

Please revert those character encoding changes.


r=dbaron with that
Attachment #8889263 - Flags: review?(dbaron) → review+
Addressed review comments.
Attachment #8889263 - Attachment is obsolete: true
Pushed by tschneider@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c5acd94ff501
(reftest) Rename reftest-print to reftest-paged. r=dbaron
Could you email dev-tech-layout (or maybe dev-platform?) to say this happened?
Flags: needinfo?(tschneider)
https://hg.mozilla.org/mozilla-central/rev/c5acd94ff501
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
(In reply to David Baron :dbaron: ⌚️UTC+1 from comment #11)
> Could you email dev-tech-layout (or maybe dev-platform?) to say this
> happened?

Done.
Flags: needinfo?(tschneider)
Assignee: nobody → tschneider
Component: Printing: Output → Reftest
Product: Core → Testing
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.